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What is Writer?
Writer is the word processor component of OpenOffice.org (OOo). In 
addition to the usual features of a word processor (spelling check, 
thesaurus, hyphenation, autocorrect, find and replace, automatic 
generation of tables of contents and indexes, mail merge and others), 
Writer provides these important features:

• Templates and styles (see Chapter 3)
• Page layout methods, including frames, columns, and tables
• Embedding or linking of graphics, spreadsheets, and other 

objects
• Built-in drawing tools
• Master documents—to group a collection of documents into a 

single document
• Change tracking during revisions
• Database integration, including a bibliography database
• Export to PDF, including bookmarks (see Chapter 10)
• And many more

These features are covered in detail in the Writer Guide.

The Writer interface
The main Writer workspace is shown in Figure 1. The menus and 
toolbars are described in Chapter 1 (Introducing OpenOffice.org).

Some other features of the Writer interface are covered in this chapter.

Figure 1: The main Writer workspace in Print Layout view
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Status bar
The Writer status bar provides information about the document and 
convenient ways to quickly change some document features.

Figure 2: Left end of status bar

Page number
Shows the current page number, the sequence number of the 
current page (if different), and the total number of pages in the 
document. For example, if you restarted page numbering at 1 on the 
third page, its page number is 1 and its sequence number is 3.
If any bookmarks have been defined in the document, a right-click 
on this field pops up a list of bookmarks; click on the required one.
To jump to a specific page in the document, double-click on this 
field. The Navigator opens. Click in the Page Number field and type 
the sequence number of the required page. After a brief delay, the 
display jumps to the selected page.

Page style
Shows the style of the current page. To change the page style, right-
click on this field. A list of page styles pops up; choose a different 
style by clicking on it.
To edit the current page style, double-click on this field. The Page 
Style dialog opens.

Language
Shows the language for the selected text.
Click to open a menu where you can choose another language for 
the selected text or for the paragraph where the cursor is located. 
You can also choose None (Do not check spelling) to exclude the 
text from a spelling check or choose More... to open the Character 
dialog.

Insert mode
Click to toggle between Insert and Overwrite modes when typing.

Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) 
and BLK (Block) selection. EXT is an alternative to Shift+click when 
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selecting text. See “Working with text” on page 11 for more 
information about ADD and BLK.

Unsaved changes
An asterisk (*) appears here if changes to the document have not 
been saved.

Figure 3: Right end of status bar

Digital signature

If the document has been digitally signed, an icon  shows here. 
You can double-click the icon to view the certificate.

Section or object information
When the cursor is on a section, heading, or list item, or when an 
object (such as a picture or table) is selected, information about that 
item appears in this field. Double-clicking in this area opens a 
relevant dialog. For details, consult the Help or the Writer Guide.

View layout
Click an icon to change between single page, side-by-side, and book 
layout views (Figure 4). You can edit the document in any view.

Figure 4: View layouts: single, side-by-side, book.
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Zoom
To change the view magnification, drag the Zoom slider, or click on 
the + and – signs, or right-click on the zoom level percent to pop up 
a list of magnification values from which to choose. Zoom interacts 
with the selected view layout to determine how many pages are 
visible in the document window.

Changing document views
Writer has several ways to view a document: Print Layout, Web Layout, 
and Full Screen. To access these and other choices, go to the View 
menu and click on the required view. (When in Full Screen view, press 
the Esc key to return to either Print or Web Layout view.)

When in Print Layout, you can use both the Zoom slider and the View 
Layout icons on the Status bar. In Web Layout, you can use the Zoom 
slider.

You can also choose View > Zoom from the menu bar to display the 
Zoom & View Layout dialog (Figure 5), where you can set the same 
options as on the Status bar. In Web Layout view, most of the choices 
are not available.

Figure 5: Choosing Zoom and View Layout options.

8 Getting Started with Writer



Moving quickly through a document
In addition to the navigation features of the Status bar (described 
above), you can use the main Navigator window and the Navigation 
toolbar as described in Chapter 1 (Introducing OpenOffice.org).

In Writer, you can also display the Navigation toolbar by clicking on the 
small Navigation icon near the lower right-hand corner of the window 
below the vertical scroll bar, as shown in Figure 6.

Figure 6: Navigation icons.

The Navigation toolbar (Figure 7) shows icons for all the object types 
shown in the Navigator, plus some extras (for example, the results of a 
Find command).

Figure 7: Navigation toolbar

Click an icon to select that object type. Now all the Previous and Next 
icons (in the Navigator itself, in the Navigation Toolbar, and on the 
scroll bar) will jump to the next object of the selected type. This is 
particularly helpful for finding items like index entries, which can be 
difficult to see in the text. The names of the icons (shown in the 
tooltips) change to match the selected category; for example, Next 
Graphic, Next Bookmark, or Continue search forward.

For more uses of the Navigator in Writer, see the Writer Guide.
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Working with documents
Chapter 1 (Introducing OpenOffice.org) includes instructions on 
starting new documents, opening existing documents, and saving 
documents. Chapter 3 (Using Styles and Templates) covers how to 
create a document from a template.

Saving as a Microsoft Word file
If you need to exchange files with users of Microsoft Word, they may 
not know how to open and save .odt files. Microsoft Word 2007 with 
Service Pack 2 (SP2) can do this. Users of Word 2007, 2003, XP, and 
2000 can also download and install a free OpenDocument Format 
(ODF) plugin from Sun Microsystems.

Some users of Microsoft Word may be unwilling or unable to receive 
*.odt files. (Perhaps their employer won’t allow them to install the 
plug-in.) In this case, you can save a document as a Microsoft Word 
file.

1) Important—First save your document in the file format used by 
OOo Writer (.odt). If you do not, any changes you made since the 
last time you saved will appear only in the Microsoft Word version 
of the document.

2) Then choose File > Save As.
3) On the Save As dialog (Figure 8), in the File type (or Save as 

type) drop-down menu, select the type of Word format you need.
4) Choose Save.

From this point on, all changes you make to the document will occur 
only in the Microsoft Word document. You have changed the name and 
file type of your document. If you want to go back to working with 
the .odt version of your document, you must open it again.

Tip

To have OOo save documents by default in the Microsoft Word 
file format, go to Tools > Options > Load/Save. See 
“Choosing options for loading and saving documents” in 
Chapter 2 (Setting up OpenOffice.org).
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Figure 8. Saving a file in Microsoft Word format

Working with text
Working with text (selecting, copying, pasting, moving) in Writer is 
similar to working with text in any other program. OOo also has some 
convenient ways to select items that are not next to each other, select a 
vertical block of text, and paste unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 9) using the 
mouse:

1) Select the first piece of text.
2) Hold down the Control key and use the mouse to select the next 

piece of text.
3) Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the 
style, or whatever).

Note
Macintosh users: substitute the Command key when 
instructions in this chapter say to use the Control key.
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Figure 9: Selecting items that are not next to each other

To select nonconsecutive items using the keyboard:
1) Select the first piece of text. (For more information about 

keyboard selection of text, see the topic “Navigating and selecting 
with the keyboard” in the Help.)

2) Press Shift+F8. This puts Writer in “Add” mode. The word ADD 
appears on the status bar.

3) Use the arrow keys to move to the start of the next piece of text 
to be selected. Hold down the Shift key and select the next piece 
of text.

4) Repeat as often as needed.

Now you can work with the selected text.

Press Esc to exit from this mode.

Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by 
spaces or tabs (as you might see in text pasted from e-mails, program 
listings, or other sources), using OOo’s block selection mode. To 
change to block selection mode, use Edit > Selection Mode > Block 
Area, or click several times in the status bar on STD until it changes to 
BLK.

Now highlight the selection, using mouse or keyboard, as shown in 
Figure 10.
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Figure 10: Selecting a vertical block of text

Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text 
in other applications. You can use the mouse or the keyboard for these 
operations. You can copy or move text within a document, or between 
documents, by dragging or by using menu selections, icons, or 
keyboard shortcuts. You can also copy text from other sources such as 
Web pages and paste it into a Writer document.

To move (cut and paste) selected text using the mouse, drag it to the 
new location and release it. To copy selected text, hold down the 
Control key while dragging. The text retains the formatting it had 
before dragging.

When you paste text, the result depends on the source of the text and 
how you paste it. If you click on the Paste icon, any formatting the text 
has (such as bold or italics) is retained. Text pasted from Web sites and 
other sources may also be placed into frames or tables. If you do not 
like the results, click the Undo icon or press Control+Z.

To make the pasted text take on the formatting of the surrounding text 
where it is being pasted,choose either:

• Edit > Paste Special, or
• Click the triangle to the right of the Paste icon, or
• Click the Paste icon without releasing the left mouse button.

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on 
the origin and formatting of the text (or other object) to be pasted. See 
(Figure 11) for an example with text on the clipboard.

Figure 11: Paste Special menu
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Finding and replacing text and formatting
Writer has a Find and Replace feature that automates the process of 
searching for text inside a document. In addition to finding and 
replacing words and phrases, you can:

• Use wildcards and regular expressions to fine-tune a search (see 
the Help for details).

• Find and replace specific formatting (see the Writer Guide ).
• Find and replace paragraph styles (see the Writer Guide).

To display the Find & Replace dialog (Figure 12), use the keyboard 
shortcut Control+F or choose Edit > Find & Replace from the menu 
bar.

1) Type the text you want to find in the Search for box.
2) To replace the text with different text, type the new text in the 

Replace with box.
3) You can select various options such as matching the case, 

matching whole words only, or doing a search for similar words.
4) When you have set up your search, click Find. To replace text, 

click Replace instead.

Figure 12: Expanded Find & Replace dialog
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Tip
If you click Find All, OOo selects all instances of the search 
text in the document. Similarly, if you click Replace All, OOo 
will replace all matches.

Caution
Use Replace All with caution; otherwise, you may end up with 
some hilarious (and highly embarrassing) mistakes. A mistake 
with Replace All might require a manual, word-by-word, 
search to fix.

Inserting special characters
A special character is one not found on a standard English keyboard. 
For example, © ¾ æ ç ñ ö ø ¢ are all special characters. To insert a 
special character:

1) Place the cursor where you want the character to appear.
2) Choose Insert > Special Character to open the Special 

Characters dialog (Figure 13).
3) Select the characters (from any font or mixture of fonts) you wish 

to insert, in order, then click OK. The selected characters are 
shown in the lower left of the dialog. As you select a character, it 
is shown on the lower right, along with its numerical code.

Note
Different fonts include different special characters. If you do 
not find a particular special character, try changing the Font 
selection.

Figure 13: The Special Characters window, 
where you can insert special characters.

Tip
Notice that the characters selected appear in the bottom-left 
corner of the window.
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Inserting dashes and non-breaking spaces and 
hyphens
To prevent two words from being separated at the end of a line, press 
Control+Shift+spacebar after the first word to insert a non-breaking 
space.

In cases where you do not want the hyphen to appear at the end of a 
line, for example in a number such as 123-4567, you can press 
Control+Shift+minus sign to insert a non-breaking hyphen.

To enter en and em dashes, you can use the Replace dashes option on 
the Options tab under Tools > AutoCorrect Options. This option 
replaces two hyphens, under certain conditions, with the 
corresponding dash.

– is an en-dash; that is, a dash the width of the letter “n” in the font 
you are using. Type at least one character, a space, one or two 
hyphens, another space, and at least one more letter, then a 
space. The one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the 
font you are using. Type at least one character, two hyphens, and 
at least one more character, then a space. The two hyphens will 
be replaced by an em-dash.

See the Help for more details. For other methods of inserting dashes, 
see the Writer Guide.

Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any tab stops 
that you have defined. Tab settings affect indentation of full 
paragraphs (using the Increase Indent and Decrease Indent icons on 
the Formatting toolbar) as well as indentation of parts of a paragraph 
(by pressing the Tab key on the keyboard).

Using the default tab spacing can cause formatting problems if you 
share documents with other people. If you use the default tab spacing 
and then send the document to someone else who has chosen a 
different default tab spacing, tabbed material will change to use the 
other person’s settings. This may cause major formatting problems. 
Instead of using the defaults, define your own tab settings, as 
described in this section.

To define indents and tab settings for one or more selected 
paragraphs, double-click on a part of the ruler that is not between the 
left and right indent icons to open the Indents & Spacing page of the 
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Paragraph dialog. Double-click anywhere between the left and right 
indent icons on the ruler to open the Tabs page of the Paragraph 
dialog.

A better strategy is to define tabs for the paragraph style. See 
Chapters 6 and 7 in the Writer Guide for more information.

Tip
Using tabs to space out material on a page is not recommended. 
Depending on what you are trying to accomplish, a table is 
usually a better choice.

Changing the default tab stop interval

Note
Any changes to the default tab setting will affect the existing 
default tab stops in any document you open afterward, as well 
as tab stops you insert after making the change.

To set the measurement unit and the spacing of default tab stop 
intervals, go to Tools > Options > OpenOffice.org Writer > 
General.

Figure 14: Selecting a default tab stop interval

You can also set or change the measurement unit for rulers in the 
current document by right-clicking on the ruler to open a list of units, 
as shown in Figure 15. Click on one of them to change the ruler to that 
unit. The selected setting applies only to that ruler.

Figure 15: Changing the 
measurement unit for a ruler
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Checking spelling and grammar
Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a 
wavy red line under any misspelled words. When the word is 
corrected, the line disappears.

To perform a separate spelling check on the document (or a text 
selection) click the Spelling and Grammar button. This checks 
the document or selection and opens the Spelling and Grammar 
dialog if any misspelled words are found.

Here are some more features of the spelling checker:
• You can right-click on a word with a wavy underline to open a 

context menu. If you select from the suggested words on the 
menu, the selection will replace the misspelled word in your text. 
Other menu options are discussed below.

• You can change the dictionary language (for example, Spanish, 
French or German) on the Spelling and Grammar dialog.

• You can add a word to the dictionary. Click Add in the Spelling 
and Grammar dialog and pick the dictionary to add it to.

• Click the Options button on the Spelling and Grammar dialog to 
open a dialog similar to the one in Tools > Options > Language 
Settings > Writing Aids described in Chapter 2. There you can 
choose whether to check uppercase words and words with 
numbers, and you can manage custom dictionaries, that is, add or 
delete dictionaries and add or delete words in a dictionary.

• On the Font tab of the Paragraph Styles dialog, you can set 
paragraphs to be checked in a specific language (different from 
the rest of the document). See Chapter 7 (Working with Styles) in 
the Writer Guide for more information.

Writer does not include a grammar checker, but you can install an 
extension such as Language Tool and access it from Tools > Spelling 
and Grammar. (See Chapter 14 for more about installing extensions.)

Language Tool adds a new menu item and submenu to the Tools menu, 
from which you can configure the tool and check or recheck the 
document.

Using built-in language tools
Writer provides some tools that make your work easier if you mix 
multiple languages within the same document or if you write 
documents in various languages.
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The main advantage of changing the language is that you can then use 
the correct dictionaries to check spelling and apply the localized 
versions of Autocorrect replacement tables, thesaurus, and 
hyphenation rules.
You can also set the language for a paragraph or a group of characters 
as None. This option is especially useful when you insert text such as 
web addresses or programming language snippets that you do not 
want to check for spelling.
Specifying the language in character and paragraph styles is the 
preferred method, because styles allow a greater level of control and 
make changing the language much faster. On the Font tab of the 
Paragraph Styles dialog, you can specify that certain paragraphs be 
checked in a language that is different from the language of the rest of 
the document. See Chapter 7 (Working with Styles) in the Writer Guide 
for information on how to manage the language settings of a style.

You can set the language for the whole document, for individual 
paragraphs, or even for individual words and characters, all from 
Tools > Language on the menu bar.

Another way to change the language of a whole document is to use 
Tools > Options > Language Settings > Languages. In the Default 
languages for documents section of the Options dialog, you can choose 
a different language for all the text.

The spelling checker works only for those languages in the list that 

have the symbol  next to them. If you do not see the symbol next to 
your preferred language, you can install the additional dictionary using 
Tools > Languages > More dictionaries online.

The language used for checking spelling is also shown in the status 
bar, next to the page style in use.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings 
and typing errors, which it corrects automatically. For example, “hte” 
will be changed to “the”. 

Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. 
There you can define which strings of text are corrected and how. In 
most cases, the defaults are fine.

AutoCorrect is turned on when Writer is installed. To turn it off, 
uncheck Format > AutoCorrect > While Typing.
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To stop Writer replacing a specific spelling, go to the Replace tab, 
highlight the word pair, and click Delete.

To add a new spelling to the list, type it into the Replace and With 
boxes on the Replace tab, and click New.

See the different tabs of the dialog for the wide variety of other options 
available to fine-tune AutoCorrect.

Tip
AutoCorrect can be used as a quick way to insert special 
characters. For example, (c)  will be autocorrected to ©. You 
can add your own special characters.

Using word completion
If Word Completion is enabled, Writer tries to guess which word you 
are typing and offers to complete the word for you. To accept the 
suggestion, press Enter. Otherwise continue typing.

To turn off Word Completion, select Tools > AutoCorrect Options > 
Word Completion and deselect Enable word completion.

You can customize word completion from the Word Completion page 
of the AutoCorrect dialog:

• Add (append) a space automatically after an accepted word.
• Show the suggested word as a tip (hovering over the word) rather 

than completing the text as you type.
• Change the maximum number of words remembered for word 

completion and the length of the smallest words to be 
remembered.

• Delete specific entries from the word completion list.
• Change the key that accepts a suggested entry—the options are 

Right arrow, End key, Return (Enter), and Space bar.

Note
Automatic word completion only occurs after you type a word 
for the second time in a document.

Using AutoText
AutoText allows you to assign text, tables, graphics and other items to 
a key combination. For example, rather than typing “Senior 
Management” every time you use that phrase, you can type “sm” and 
press F3. You can also  save graphics or tables (such as a formatted Tip 
like the one on this page) as AutoText.
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To assign some text to an AutoText shortcut:
1) Type the text into your document.
2) Select the text so it is highlighted.
3) Choose Edit > AutoText (or press Control+F3).
4) Enter a name for your shortcut. Writer will suggest a one-letter 

shortcut, which you can change.
5) Click the AutoText button on the right and select New (text 

only) from the menu.
6) Click Close to return to your document.

Tip
If the only option under the AutoText button is Import, either 
you have not entered a name for your AutoText or there is no 
text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 
14 (Working with Fields) in the Writer Guide for more information.

Formatting text

Using styles is recommended
Styles are central to using Writer. Styles enable you to easily format 
your document consistently, and to change the format with minimal 
effort. A style is a named set of formatting options. Writer defines 
several types of styles, for different types of elements: characters, 
paragraphs, pages, frames, and lists. See Chapter 3 (Using Styles and 
Templates) in this book and Chapters 6 and 7 in the Writer Guide.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the 
Formatting toolbar. Figure 16 shows the Formatting toolbar as a 
floating toolbar, customized to show only the icons for paragraph 
formatting. The appearance of the icons may vary with your operating 
system and the selection of icon size and style in Tools > Options > 
OpenOffice.org > View.
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1 Open Styles and 
Formatting Window

5 Align Right 10 Numbering On/Off
6 Justified 11 Bullets On/Off

2 Apply Style 7 Line Spacing: 1 12 Decrease Indent
3 Align Left 8 Line Spacing: 1.5 13 Increase Indent
4 Centered 9 Line Spacing: 2 14 Paragraph format dialog

Figure 16: Formatting toolbar, showing icons for paragraph 
formatting

Formatting characters
You can apply many formats to characters using the buttons on the 
Formatting toolbar. Figure 17 shows the Formatting toolbar, 
customized to include only the icon for character formatting.

The appearance of the icons may vary with your operating system and 
the selection of icon size and style in Tools > Options > 
OpenOffice.org > View.

1 Open Styles and Formatting 
Window

6 Italic 12 Font Color
7 Underline 13 Highlighting

2 Apply Style 8 Superscript 14 Background Color
3 Font Name 9 Subscript 15 Open Character Format 

Dialog4 Font Size 10 Increase Font
5 Bold 11 Reduce Font

Figure 17: Formatting toolbar, showing icons for character formatting

Tip
To remove manual formatting, select the text and choose 
Format > Default Formatting, or right-click and choose 
Default Formatting.

Autoformatting
You can set Writer to automatically format parts of a document 
according to the choices made on the Options page of the AutoCorrect 
dialog (Tools > AutoCorrect Options).
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Tip
If you notice unexpected formatting changes occurring in your 
document, this is the first place to look for the cause.

Some common unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), 
underscores (___) or equal signs (===) on a line and then press 
Enter, the paragraph is replaced by a horizontal line as wide as 
the page. The line is actually the lower border of the preceding 
paragraph.

• Bulleted and numbered lists. A bulleted list is created when you 
type a hyphen (-), star (*), or plus sign (+), followed by a space or 
tab at the beginning of a paragraph. A numbered list is created 
when you type a number followed by a period (.), followed by a 
space or tab at the beginning of a paragraph. Automatic 
numbering is only applied to paragraphs formatted with the 
Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, choose Format > AutoCorrect and 
select or deselect the items on the list.

Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.
• Use list (numbering) styles, as described in Chapters 6 

(Introduction to Styles) and 7 (Working with Styles) in the Writer 
Guide.

• Use the Numbering and Bullets icons on the paragraph 
formatting toolbar (see Figure 16): select the paragraphs in the 
list, and then click the appropriate icon on the toolbar.

Note
It is a matter of personal preference whether you type your 
information first, then apply Numbering/Bullets, or apply them 
as you type.

Using the Bullets and Numbering toolbar
You can create nested lists (where one or more list items has a sublist 
under it, as in an outline) by using the buttons on the Bullets and 
Numbering toolbar (Figure 18). You can move items up or down the 
list, or create subpoints, and even change the style of bullets. Use 
View > Toolbars > Bullets and Numbering to see the toolbar.
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The appearance of the icons may vary with your operating system and 
the selection of icon size and style in Tools > Options > 
OpenOffice.org > View.

1 Bullets On/Off 6 Move Up (One Level) with 
Sub-points

10 Move Down
2 Numbering On/Off 11 Move Up in Sub-points
3 Numbering Off 7 Move Down (One Level) with 

Sub-points
12 Move Down in Sub-points

4 Up One Level 8 Insert Unnumbered Entry 13 Restart Numbering
5 Down One Level 9 Move Up 14 Bullets and Numbering

Figure 18: Bullets and Numbering toolbar

Hyphenating words
You have several choices regarding hyphenation: let Writer do it 
automatically (using its hyphenation dictionaries), insert conditional 
hyphens manually where necessary, or don’t hyphenate at all.

Automatic hyphenation
To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window.

Figure 19: Modifying a style

2) On the Paragraph Styles page of the Styles and Formatting 
window, right-click on Default in the list and select Modify.

3) On the Paragraph Style dialog, go to the Text Flow page.
4) Under Hyphenation, select or deselect the Automatically option. 

Click OK to save.
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Figure 20: Turning on automatic hyphenation

Note

Turning on hyphenation for the Default paragraph style affects 
all other paragraph styles that are based on Default. You can 
individually change other styles so that hyphenation is not 
active; for example, you might not want headings to be 
hyphenated. Any styles that are not based on Default are not 
affected.

You can also set hyphenation choices through Tools > Options > 
Language Settings > Writing Aids. In Options, near the bottom of 
the dialog, scroll down to the find the hyphenation settings.

Figure 21: Setting hyphenation options

To change the minimal number of characters for hyphenation, the 
minimum number of characters before a line break, or the minimum 
number of characters after a line break, select the item, and then click 
the Edit button in the Options section.

Hyphenation options set on the Writing Aids dialog are effective only if 
hyphenation is turned on through paragraph styles.

Manual hyphenation
To manually hyphenate words, do not use a normal hyphen, which will 
remain visible even if the word is no longer at the end of a line when 
you add or delete text or change margins or font size. Instead, use a 
conditional hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the 
hyphen to appear and press Control+hyphen. The word will be 
hyphenated at this position when it is at the end of the line, even if 
automatic hyphenation for this paragraph is switched off.
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Formatting pages
Writer provides several ways for you to control page layouts: page 
styles, columns, frames, tables, and sections. For more information, 
see Chapter 4 (Formatting Pages) in the Writer Guide.

Tip

Page layout is usually easier if you show text, object, table, and 
section boundaries in Tools > Options > OpenOffice.org > 
Appearance, and paragraph ends, tabs, breaks, and other 
items in Tools > Options > OpenOffice.org Writer > 
Formatting Aids.

Which layout method to choose?
The best layout method varies depending on what the final document 
should look like and what sort of information will be in the document. 
Here are some examples.

For a book similar to this user guide, 
with one column of text, some figures 
without text beside them, and some 
other figures with descriptive text, use 
page styles for basic layout, and tables 
to place figures beside descriptive text 
when necessary.
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For an index or other document with 
two columns of text, where the text 
continues from the left-hand column to 
the right-hand column and then to the 
next page, all in sequence (also known 
as “snaking columns” of text), use page 
styles (with two columns). If the title of 
the document (on the first page) is full-
page width, put it in a single-column 
section.

For a newsletter with complex layout, 
two or three columns on the page, and 
some articles that continue from one 
page to some place several pages later, 
use page styles for basic layout. Place 
articles in linked frames and anchor 
graphics to fixed positions on the page 
if necessary.

For a document with terms and 
translations to appear side-by-side in 
what appear to be columns, use a table 
to keep items lined up, and so you can 
type in both “columns”.
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Creating headers and footers
A header is an area that appears at the top of a page. A footer appears 
at the bottom of the page. Information, such as page numbers inserted 
into a header or footer, displays on every page of the document with 
that page style.

To insert a header, choose Insert > Header > Default (or the page 
style, if not Default).

Other information such as document titles and chapter titles is often 
put into the header or footer. These items are best added as fields. 
That way, if something changes, the headers and footers are updated 
automatically. Here is one common example.

To insert the document title into the header:
1) Choose File > Properties > Description and type a title for 

your document.
2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.
4) Choose Insert > Fields > Title.  The title should appear on a 

gray background (which does not show when printed and can be 
turned off).

5) To change the title for the whole document, go back to File > 
Properties > Description.

Fields are covered in detail in Chapter 14 (Working with Fields) in the 
Writer Guide.

For more about headers and footers, see Chapter 4 (Formatting Pages) 
and Chapter 6 (Introduction to Styles) in the Writer Guide.

Numbering pages
To automatically number pages:

1) Insert a header or footer, as described in “Creating headers and
footers” on page 28.

2) Place the cursor in the header or footer where you want the page 
number to appear and choose Insert > Fields > Page Number. 

Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):

1) Type the word “page” and a space, then insert the page number 
as above.
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2) Press the spacebar once, type the word “of” and a space, then 
choose Insert > Fields > Page Count.

Note

The Page Count field inserts the total number of pages in the 
document, as shown on the Statistics tab of the document’s 
Properties window (File > Properties). If you restart page 
numbering anywhere in the document, then the total page 
count may not be what you want. See Chapter 4 (Formatting 
Pages) in the Writer Guide for more information.

Restarting page numbering
Often you will want to restart the page numbering at 1, for example on 
the page following a title page or a table of contents. In addition, many 
documents have the “front matter” (such as the table of contents) 
numbered with Roman numerals and the main body of the document 
numbered in Arabic numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:
1) Place the cursor in the first paragraph of the new page.
2) Choose Format > Paragraph.
3) On the Text Flow tab of the Paragraph dialog (Figure 20 on page 

25), select Breaks.
4) Select Insert and then With Page Style and specify the page 

style to use.
5) Specify the page number to start from, and then click OK.

Tip

Method 1 is also useful for numbering the first page of a 
document with a page number greater than 1. For example, 
you may be writing a book, with each chapter in a separate 
file. Chapter 1 may start with page 1, but Chapter 2 could 
begin with page 25 and Chapter 3 with page 51.

Method 2:
1) Insert > Manual break.
2) By default, Page break is selected on the Insert Break dialog 

(Figure 22).
3) Choose the required page Style.
4) Select Change page number.
5) Specify the page number to start from, and then click OK.
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Figure 22: Restarting page numbering 
after a manual page break

Changing page margins
You can change page margins in two ways:

• Using the page rulers—quick and easy, but does not have fine 
control.

• Using the Page Style dialog—can specify margins to two decimal 
places.

Note

If you change the margins using the rulers, the new margins 
affect the page style and will be shown in the Page Style dialog 
the next time you open it.

Because the page style is affected, the changed margins apply 
to all pages using that style.

To change margins using the rulers:
1) The gray sections of the rulers are the margins (see Figure 23). 

Put the mouse cursor over the line between the gray and white 
sections. The pointer turns into a double-headed arrow.

2) Hold down the left mouse button and drag the mouse to move the 
margin.

Figure 23: Moving the margins
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Tip

The small arrows on the ruler are used for indenting 
paragraphs. They are often in the same place as the page 
margins, so you need to be careful to move the margin marker, 
not the arrows. Place the mouse pointer between the arrows 
and, when the pointer turns into a double-headed arrow, you 
can move the margin (the indent arrows will move with it).

To change margins using the Page Style dialog:
1) Right-click anywhere on the page and select Page from the pop-

up menu.
2) On the Page tab of the dialog, type the required distances in the 

Margins boxes.

Adding comments to a document
Authors and reviewers often use comments (formerly called “notes”) to 
exchange ideas, ask for suggestions, or mark items needing attention.

To insert a comment in the text, place the cursor in the place the 
comment refers to and choose Insert > Comment or press 
Ctrl+Alt+N. The anchor point of the comment is connected by a dotted 
line to a box on the right-hand side of the page where you can type the 
text of the comment. Writer automatically adds at the bottom of the 
comment the author’s name and a time stamp indicating when the 
comment was created. Figure 24 shows an example of text with 
comments from two different authors.

Figure 24: Example of comments
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Choose Tools > Options > User Data to configure the name you want 
to appear in the Author field of the comment, or to change it.

If more than one person edits the document, each author is 
automatically allocated a different background color.

Right-clicking on a comment pops up a menu where you can delete the 
current comment, all the comments from the same author, or all the 
comments in the document. From this menu, you can also apply some 
basic formatting to the text of the comment. You can also change the 
font type, size, and alignment from the main menu.

To navigate from one comment to another, open the Navigator (F5), 
expand the Comments section, and click on the comment text to move 
the cursor to the anchor point of the comment in the document. Right-
click on the comment to quickly edit or delete it.

You can also navigate through the comments using the keyboard. Use 
Ctrl+Alt+Page Down to move to the next comment and 
Ctrl+Alt+Page Up to move to the previous comment.

Creating a table of contents
Writer’s table of contents feature lets you build an automated table of 
contents from the headings in your document. Before you start, make 
sure that the headings are styled consistently. For example, you can 
use the Heading 1 style for chapter titles and the Heading 2 and 
Heading 3 styles for chapter subheadings.

Although tables of contents can be customized extensively in Writer, 
often the default settings are all you need. Creating a quick table of 
contents is simple:

1) When you create your document, use the following paragraph 
styles for different heading levels (such as chapter and section 
headings): Heading 1, Heading 2, Heading 3, and so on. These 
are what will appear in your table of contents.

2) Place the cursor where you want the table of contents to be 
inserted.

3) Choose Insert > Indexes and Tables > Indexes and Tables.
4) Change nothing in the Insert Index/Table dialog. Click OK.

If you add or delete text (so that headings move to different pages) or 
you add, delete, or change headings, you need to update the table of 
contents.
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To do this:

1) Place the cursor within the table of contents.
2) Right-click and choose Update Index/Table from the pop-up 

menu.

Note

If you cannot place your cursor in the table of contents, choose 
Tools > Options > OpenOffice.org Writer > Formatting 
Aids, and then select Enable in the Cursor in protected 
areas section.

You can customize an existing table of contents at any time. Right-click 
anywhere in it and choose Edit Index/Table from the pop-up menu. 
Chapter 12 (Creating Tables of Contents, Indexes and Bibliographies) 
of the Writer Guide describes in detail all the customizations you can 
choose.

Creating indexes and bibliographies
Indexes and bibliographies work in a similar way to tables of contents. 
Chapter 12 (Creating Tables of Contents, Indexes and Bibliographies) 
in the Writer Guide describes the process in detail.

In addition to alphabetical indexes, other types of indexes supplied 
with Writer include those for illustrations, tables, and objects, and you 
can even create a user-defined index. For example, you might want an 
index containing only the scientific names of species mentioned in the 
text, and a separate index containing only the common names of 
species. Before creating some types of indexes, you first need to create 
index entries embedded in your Writer document.

Working with graphics
Graphics in Writer are of three basic types:

• Image files, including photos, drawings, scanned images, and 
others

• Diagrams created using OOo’s drawing tools
• Charts created using OOo’s Chart facility.

See Chapter 11 (Graphics, the Gallery, and Fontwork) in this book and 
Chapter 8 (Working with Graphics) in the Writer Guide.
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Printing from Writer
Writer provides a range of choices when printing.

Quick printing

Click the Print File Directly icon  to send the entire document to 
the default printer defined for your computer.

Note

You can change the action of the Print File Directly icon to 
send the document to the printer defined for the document 
instead of the default printer for the computer. Go to Tools > 
Options > Load/Save > General and select the Load 
printer settings with the document option.

Controlling printing
For more control over printing, use File > Print to display the Print 
dialog (Figure 25).

Figure 25. The Print dialog

On the Print dialog, you can choose:

• Which printer to use (if more than one are installed on your 
system) and the properties of the printer—for example, orienta-
tion (portrait or landscape), which paper tray to use, and what 
paper size to print on. The properties available depend on the 
selected printer; consult the printer’s documentation for details.
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• What pages to print, how many copies to print, and in what order 
to print them. Use dashes to specify page ranges and commas or 
semicolons to separate ranges; for example: 1, 5, 11–14, 34–40. 
Selection is the highlighted part of a page or pages.

• What items to print. Click the Options button to display the 
Printer Options dialog (Figure 26).

Figure 26. Printer Options dialog for Writer

Selecting print options for a document
Selections on the Printer Options dialog apply to this printing of this 
document only.

To specify default printing options, you need to use two pages in Tools 
> Options > OpenOffice.org – Print and Tools > Options > 
OpenOffice.org Writer – Print (which looks very similar to the 
Printer Options dialog). (See Chapter 2.)

Some items of interest on the Printer Options dialog include:

• In the Contents section, you might choose not to print graphics or 
page background in drafts, for example (to save toner or ink).

• In the Pages section, you can choose:
– Print only left (even-numbered) pages or only right (odd-

numbered) pages. These settings are useful when you want to 
print on both sides of the page, but do not have a printer that 
handles this automatically.

– Print in reversed page order.
– Brochure—the results of this selection are discussed in 

“Printing a brochure” on page 37.

Printing from Writer 35



• In the Comments section, you can choose whether to print any 
comments that have been added to your document (using Insert 
> Comment), and where to print the comments.

Printing in black and white on a color printer
You may wish to print documents in black and white on a color printer, 
to save expensive color ink or toner. Common uses are for drafts or 
documents to be photocopied in black and white. Several choices are 
available.

To print the current document in black and white or grayscale:

1) Choose File > Print to open the Print dialog.
2) Click Properties to open the properties dialog for the printer. 

The available choices vary from one printer to another, but you 
should find an option for Color. See your printer’s help or user 
manual for more information.

3) The choices for color may include black and white or grayscale. 
Choose one of these. Grayscale is best if you have any graphics in 
the document. Click OK to confirm your choice and return to the 
Print dialog, then click OK again to print the document.

To set up OOo to print all color text and graphics as grayscale:

1) Choose Tools > Options > OpenOffice.org > Print.
2) Select the Convert colors to grayscale option. Click OK to save 

the change.

To set up OOo Writer to print all color text as black, and all graphics as 
grayscale:

1) Choose Tools > Options > OpenOffice.org Writer > Print.
2) Under Contents, select the Print black option. Click OK to save 

the change.

Previewing pages before printing
The normal page view in Writer shows you what each page will look 
like when printed, but it shows only one page at a time. If you are 
designing a document to be printed double-sided, you may want to see 
what facing pages look like. OOo provides two ways to do this:

• View Layout (editable view) —see “View layout” on page 7.
• Page Preview (read-only view) —from which you can print 

multiple pages onto one sheet of paper.
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To use Page Preview:
1) Choose File > Page Preview, or click the Page Preview button 

.
The Writer window changes to display the current page and the 
following page, and shows the Page Preview toolbar in place of 
the Formatting toolbar.

Figure 27. Page Preview toolbar

2) Click the Book Preview icon  to display left and right pages in 
their correct orientation.

3) To print the document from this page view, click the Print page 

view icon  to open the Print dialog. Choose your options and 
click OK to print as usual.

4) To choose margins and other options for the printout, click the 

Print options page view icon  to display the Print Options 
dialog.

Figure 28. Print Options dialog

Printing a brochure
You can print a document with two pages on each side of a sheet of 
paper, arranged so that when the printed pages are folded in half, the 
pages are in the correct order to form a booklet or brochure.

To print a brochure on a single-sided printer:

1) Plan your document so it will look good when printed half size 
(choose appropriate margins, font sizes, and so on). Choose File 
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> Print. In the Print dialog, click Properties and be sure the 
printer is set to the same orientation (portrait or landscape) as 
specified in the page setup for your document. (Usually the 
orientation does not matter, but it does for brochures.)

2) Click Options. In the Pages section of the Printer Options dialog, 
choose Brochure and Right pages. Click OK twice to print the 
first side of each page.

3) Flip the pages and put them back into the printer, in the correct 
orientation to print on the blank side. You may need to 
experiment a bit to find out what the correct arrangement is for 
your printer.

4) Choose File > Print and check Properties to make sure the 
printer setup is still correct.

5) Click Options again. In the Pages section of the Printer Options 
dialog, choose Brochure and Left page. Click OK twice to print 
the second sides.

6) If your printer can do double-sided, then click on the options for 
Left pages, Right pages, and Brochure, and it should not only 
do those but collate too.

Printing envelopes
Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with your document:

1) Choose Insert > Envelope from the menu bar.
2) In the Envelope dialog, start with the Envelope tab (Figure 29). 

Verify, add, or edit the information in the Addressee and Sender 
boxes (the “from” on the envelope).
You can type information directly into the Addressee and Sender 
boxes, or use the right-hand drop-down lists to select the 
database or table from which you can draw the envelope 
information, if desired. See Chapter 11 (Using Mail Merge) in the 
Writer Guide for details on how to print envelopes from a 
database.

3) On the Format page (Figure 30), verify or edit the positioning of 
the addressee and the sender information. The preview area on 
the lower right shows the effect of your positioning choices.
To format the text of these blocks, click the Edit buttons to the 
right. In the drop-down list you have two choices: Character and 
Paragraph.
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• In Character, you can choose Fonts (Sizes...), Fonts Effects 
(Underlining, Color...), Position (Rotating/scaling...), 
Hyperlink, Background and more.

• In Paragraph, you can choose Indents & Spacing, Alignment, 
Text Flow, Tabs, Drop Caps, Borders and Backgrounds.

Figure 29. Choosing addressee and sender information

Figure 30. Choosing positioning and size of elements 
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4) In the lower left of this page, choose the envelope format from the 
drop-down list. The width and height of the selected envelope 
then show in the boxes below the selected format. If you chose a 
pre-existing format, just verify these sizes. If you chose User 
defined in the Format list, then you can edit the sizes.

5) After formatting, go to the Printer page (Figure 31) to choose 
printer options such as envelope orientation and shifting. You may 
need to experiment a bit to see what works best for your printer.
You can also choose a different printer or alter printer setup (for 
example, specify the tray that holds envelopes) for this print job.

Figure 31. Choosing printer options for an envelope

6) When you have finished formatting and are ready to print, click 
either the New Doc or Insert button to finish. New Doc makes 
only an envelope or starts a new document with the envelope. 
Insert inserts the envelope into an existing document as page 1.
To not proceed with this envelope, click Cancel or press the Esc 
key. You can also click Reset to remove your changes and return 
to the original settings when the dialog opened.

7) When the Envelope dialog closes, you are returned to your 
document, which now has the envelope in the same file as the 
document. Save this file before you do anything else.

To print the envelope:

1) Choose File > Print from the menu bar.
2) On the Print dialog, under Print range, choose Pages and type 1 

in the box. Click OK to print.
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Printing labels
Labels are commonly used for printing address lists (where each label 
shows a different address), but they can also be used for making 
multiple copies of one label only, for example return-address stickers.

To print labels:

1) Choose File > New > Labels on the menu bar. The Labels dialog 
opens.

2) On the Labels page, fill in your own label text in the Inscription 
box, or use the Database and Table drop-down lists to choose the 
required information, as described in Chapter 11 (Using Mail 
Merge) in the Writer Guide.

Figure 32. Labels dialog, Labels page

3) Select the label stock in the Brand drop-down list. The types for 
that brand then appear in the Type drop-down list. Select the size 
and type of labels required. You can also select User in the Type 
drop-down list and then make specific selections on the Format 
page.

4) On the Format page (Figure 33), choose the pitch, sizes, margins, 
columns and rows for user-defined labels, or just verify with a 
brand of label stock you have loaded into the printer.
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Figure 33. Labels dialog, Format page

5) Click Save to save your new format.
6) When you have finished formatting, click New Document to 

make your sheet of labels or click Cancel (or press the Esc key). 
You can also click Reset to remove your changes and return to 
the original settings when the dialog opened. On the Options 
page, choose to print the entire page of labels or one single label, 
then select which one by the column and row. You can also 
change printer setup.

7) You can print right away using the Print File Directly icon on 
the toolbar or by choosing File > Print from the menu bar, or you 
can save the file to print later.

Figure 34. Labels dialog, Options page

Sending a fax using Writer
To send a fax directly from OpenOffice.org, you need a fax modem and 
a fax driver that allows applications to communicate with the fax 
modem.
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Sending a fax through the Print dialog
1) Open the Print dialog by choosing File > Print and select the fax 

driver in the Name list.
2) Click OK to open the dialog for your fax driver, where you can 

select the fax recipient.

Adding a Fax icon to the toolbar
You can configure OpenOffice.org so that a single click on an icon 
automatically sends the current document as a fax. See Chapter 14 
(Customizing OpenOffice.org) for instructions.

Tracking changes to a document
You can use several methods to keep track of changes made to a 
document.

1) Make your changes to a copy of the document (stored in a 
different folder, or under a different name, or both), then use 
Writer to combine the two files and show the differences. Choose 
Edit > Compare Document. This technique is particularly 
useful if you are the only person working on the document, as it 
avoids the increase in file size and complexity caused by the other 
methods.

2) Save versions that are stored as part of the original file. However, 
this method can cause problems with documents of non-trivial 
size or complexity, especially if you save a lot of versions. Avoid 
this method if you can.

3) Use Writer’s change marks (often called “redlines” or “revision 
marks”) to show where you have added or deleted material, or 
changed formatting. Choose Edit > Changes > Record. Later, 
you or another person can review and accept or reject each 
change. Right-click on an individual change and choose Accept 
Change or Reject Change from the pop-up menu, or choose 
Edit > Changes > Accept or Reject to view the list of changes 
and accept or reject them. Details are in the Writer Guide.

Tip
Not all changes are recorded. For example, changing a tab 
stop from align left to align right, and changes in formulas 
(equations) or linked graphics are not recorded.
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Using fields
Fields are extremely useful features of Writer. They are used for data 
that changes in a document (such as the current date or the total 
number of pages) and for inserting document properties such as name, 
author, and date of last update. Fields are the basis of cross-
referencing (see below); automatic numbering of figures, tables, 
headings, and other elements; and a wide range of other functions—far 
too many to describe here. See Chapter 14 (Working with Fields) in the 
Writer Guide for details.

Linking to another part of a document
If you type in cross-references to other parts of a document, those 
references can easily get out of date if you reorganize the order of 
topics, add or remove material, or reword a heading. Writer provides 
two ways to ensure that your references are up to date, by inserting 
links to other parts of the same document or to a different document:

• Hyperlinks
• Cross-references

The two methods have the same result if you Control+click the link 
when the document is open in Writer: you are taken directly to the 
cross-referenced item. However, they also have major differences:

• The text in a hyperlink does not automatically update if you 
change the text of the linked item (although you can change it 
manually), but changed text does automatically update in a cross-
reference.

• When using a hyperlink, you do not have a choice of the content 
of the link (for example text or page number), but when using a 
cross-reference, you have several choices, including bookmarks.

• To hyperlink to an object such as a graphic, and have the 
hyperlink show useful text such as Figure 6, you need to either 
give such an object a useful name instead of leaving it as the 
default name (“Graphics6”), or you need to use the Hyperlink 
dialog to modify the visible text. In contrast, cross-references to 
figures with captions automatically show useful text, and you 
have a choice of several variations of the name.

• If you save a Writer document to HTML, hyperlinks remain active 
but cross-references do not. (Both remain active when the 
document is exported to PDF.)
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Using hyperlinks
The easiest way to insert a hyperlink to another part of the same 
document is by using the Navigator:

1) Open the document containing the items you want to cross-
reference.

2) Open the Navigator (by clicking its icon, choosing View > 
Navigator, or pressing F5.

3) Click the arrow next to the Drag Mode icon, and choose Insert 
as Hyperlink. (See Figure 35.)

4) In the list at the bottom of the Navigator, select the document 
containing the item that you want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a 
hyperlink.

6) Drag the item to where you want to insert the hyperlink in the 
document. The name of the item is inserted in the document as an 
active hyperlink.

Figure 35: Inserting a hyperlink using the Navigator

You can also use the Hyperlink dialog to insert and modify hyperlinks 
within and between documents. See Chapter 12 (Creating Web Pages).

Using cross-references
If you type in references to other parts of the document, those 
references can easily get out of date if you reword a heading, add or 
remove figures, or reorganize topics. Replace any typed cross-
references with automatic ones and, when you update fields, all the 
references will update automatically to show the current wording or 
page numbers. The Cross-references tab of the Fields dialog lists some 
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items, such as headings, bookmarks, figures, tables, and numbered 
items such as steps in a procedure. You can also create your own 
reference items; see “Setting References” in Chapter 14 (Working with 
Fields) in the Writer Guide for instructions.

To insert a cross-reference to a heading, figure, bookmark, or other 
item:

1) In your document, place the cursor where you want the cross-
reference to appear.

2) If the Fields dialog is not open, click Insert > Cross-reference. 
On the Cross-references tab, in the Type list, select the type of 
item to be referenced (for example, Heading or Figure).

Figure 36: The Cross-references tab of the Fields dialog 

You can leave this page open while you insert many cross-
references.

3) Click on the required item in the Selection list, which shows all 
the items of the selected type. In the Format list, choose the 
format required. Usually this will be Reference (to insert the full 
text of the heading or caption), Category and Number (to insert 
the word “Figure” or “Table” and its number, but without the 
caption text), Numbering (to insert only the figure or table 
number, without the word “Figure” or “Table”), or Page (to insert 
the number of the page the referenced text is on). Click Insert.
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Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly 
from there with a single mouse click. You can cross-reference to 
bookmarks and create hyperlinks to bookmarks, as described above.

1) Select the text you want to bookmark. Click Insert > Bookmark.
2) On the Insert Bookmark dialog, the larger box lists any previously 

defined bookmarks. Type a name for this bookmark in the top 
box, and then click OK to save.

Figure 37: Inserting a bookmark

Using mail merge
Writer provides very useful features to create and print:

• Multiple copies of a document to send to a list of different 
recipients (form letters)

• Mailing labels
• Envelopes

All these facilities, though different in application, are based around 
the concept of a registered data source (a spreadsheet or database 
containing the name and address records and other information), from 
which is derived the variable information necessary to their function.

Chapter 11 (Using Mail Merge) in the Writer Guide describes the 
process.

Using master documents
Master documents are typically used for producing long documents 
such as a book, a thesis, or a long report; or when different people are 
writing different chapters or other parts of the full document, so you 
don’t need to share files. A master document joins separate text 
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documents into one larger document, and unifies the formatting, table 
of contents (TOC), bibliography, index, and other tables or lists.

Yes, master documents do work in Writer. However, until you become 
familiar with them, you may think that master documents are 
unreliable or difficult to use. See Chapter 13 (Working with Master 
Documents) in the Writer Guide.

Creating fill-in forms
A standard text document displays information: a letter, report, or 
brochure, for example. Typically the reader may edit everything or 
nothing in any way. A form has sections that are not to be edited, and 
other sections that are designed for the reader to make changes. For 
example, a questionnaire has an introduction and questions (which do 
not change) and spaces for the reader to enter answers.

Forms are used in three ways:

• To create a simple document for the recipient to complete, such 
as a questionnaire sent out to a group of people who fill it in and 
return it.

• To link into a database or data source and allow the user to enter 
information. Someone taking orders might enter the information 
for each order into a database using a form.

• To view information held in a database or data source. A librarian 
might call up information about books.

Writer offers several ways to fill information into a form, including 
check boxes, option buttons, text boxes, pull-down lists and spinners. 
See Chapter 15 (Using Forms in Writer) in the Writer Guide.
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