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What is Writer?

Writer is the word processor component of Apache OpenOffice (AOO). It provides the 
usual features of a word processor: enter and edit text, check spelling, thesaurus, 
hyphenation, autocorrect, find and replace, automatic generation of tables of 
contents and indexes, mail merge, and others.

In addition, Writer provides these important features:

• Templates and styles

• Page-layout methods, including frames, columns, and tables

• Embedding or linking of graphics, spreadsheets, and other objects

• Built-in drawing tools

• Master documents—to group a collection of documents into a single document

• Change tracking during revisions

• Database integration, including a bibliography database

• Export to PDF, including bookmarks

• And many more

Styles are central to using Writer. Using styles, you can easily format your document 
consistently and change the format with minimal effort. A style is a named set of 
formatting options. Writer defines several types of styles, for different types of 
elements: characters, paragraphs, pages, frames, and lists. Often, you are using 
styles whether you realize it or not. The use of styles is described in more detail in 
Chapter 6 (Introduction to Styles) and Chapter 7 (Working with Styles).

The other features of Writer listed above are covered in other chapters of this guide.

Parts of the Main Writer Window

The main Writer workspace is shown in Figure 1. Its features are described in this 
section.

Title Bar
The Title bar, located at the top of the Writer window, shows the file name of the 
current document. When the document is newly created, the document name will 
appear as Untitled X, where X is a number.

Menus
The Menu bar is located just below the Title bar. When you choose one of the menus 
listed below, a submenu drops to show commands.

• File contains commands that apply to the entire document such as Open, 
Save, Print, and Export as PDF.

• Edit contains commands for editing the document such as Undo: xxx (where 
xxx is the command to undo) and Find & Replace. It also contains 
commands to cut, copy, and paste selected parts of your document.

• View contains commands for controlling the display of the document such as 
Zoom and Web Layout.

• Insert contains commands for inserting elements into your document such as 
headers, footers, and pictures.
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• Format contains commands, such as Styles and Formatting, Paragraph, 
and Bullets and Numbering, for formatting the layout of your document

• Table shows all commands to insert and edit a table in a text document.

• Tools contain functions such as Spelling and Grammar, Customize, and 
Options. (On macOS, Options is under OpenOffice > Preferences)

• Window contains commands for the display window.

• Help contains links to the OpenOffice Help file, What’s This?, and information 
about the program. See “Getting Help” on page 24.

Toolbars
Writer has several types of toolbars: docked (fixed in place), floating, and tear-off. 
Docked toolbars can be moved to different locations or made to float, and floating 
toolbars can be docked.

The top toolbar, just under the Menu bar, is called the Standard toolbar. It is 
consistent across the OpenOffice applications (Writer, Calc, Draw, Impress).

The second toolbar at the top is the Formatting bar. It is context-sensitive; that is, it 
shows the tools relevant to the cursor’s current position or selection. For example, 
when the cursor is on a graphic, the Formatting bar provides tools for formatting 
graphics; when the cursor is in text, the tools are for formatting text.
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Displaying or Hiding Toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a 
toolbar in the list. An active toolbar shows a check mark beside its name. Tear-off 
toolbars are not listed in the View menu.

Submenus and Tear-off Toolbars
Toolbar icons with a small triangle to the right will display submenus, tear-off 
toolbars, and other ways of selecting things, depending on the icon.

An example of a tear-off toolbar is shown in Figure 2. Tear-off toolbars can be floating 
or docked along an edge of the screen or in one of the existing toolbar areas. To move 
a floating tear-off toolbar, drag it by the title bar, as shown in Figure 4.

 

Figure 2: Example of a tear-off toolbar

Moving Toolbars
To move a docked toolbar, place the mouse pointer over the toolbar handle, hold 
down the left mouse button, drag the toolbar to the new location, and then release 
the mouse button.

Figure 3: Moving a docked toolbar

To move a floating toolbar, click on its title bar and drag it to a new location.
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Floating Toolbars
Writer includes several additional context-sensitive toolbars, whose defaults appear 
as floating toolbars in response to the cursor’s current position or selection. For 
example, when the cursor is in a table, a floating Table toolbar appears, and when the 
cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears. 
You can dock these toolbars to the top, bottom, or side of the window, if you wish (see 
“Moving Toolbars” on page 6).

Docking/Floating Windows and Toolbars
Toolbars and some windows, such as the Navigator and the Styles and Formatting 
window, are dockable. You can move, resize, or dock them to an edge.

To dock a window or toolbar, hold down the Control key and double-click on the frame 
of the floating window (or in a vacant area near the icons at the top of the floating 
window) to dock it in its last position.

Figure 5: Control+click to dock or undock

To undock a window, hold down the Control key and double-click on the frame (or a 
vacant area near the icons at the top) of the docked window.

Customizing Toolbars
You can customize toolbars in several ways, including choosing which icons are 
visible and locking the position of a docked toolbar.

To access a toolbar’s customization options, use the down-arrow at the end of the 
toolbar or on its title bar (Figure 6).

To show or hide icons defined for the selected toolbar, choose Visible Buttons from 
the drop-down menu. Visible icons are indicated by a border around the icon (Figure 
7). Click on icons to hide or show them on the toolbar.

You can also add icons and create new toolbars, as described in Chapter 16.
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Right-click (Context) Menus
Right-click on a paragraph, graphic, or other object to open a context menu. Often, 
the context menu is the fastest and easiest way to reach a function. If you’re not sure 
where in the menus or toolbars a function is located, you can typically find it by right-
clicking.

Rulers
To show or hide rulers, choose View > Ruler. To enable the vertical ruler, select 
Tools > Options > OpenOffice Writer > View and select Vertical ruler.

Figure 8. Turning on the vertical ruler

Status Bar
The Writer status bar is located at the bottom of the workspace. It provides 
information about the document and convenient ways to quickly change some 
document features.
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Page number
Shows the current page number, the sequence number of the current page (if 
different from the page number), and the total number of pages in the document. 
For example, if a document has 14 pages, and you restarted page numbering at 1 
on the third page, its page number is 1, its sequence number is 3, and the total 
number of pages is 14; this field would show 1 3/14.

If any bookmarks have been defined in the document, a right-click on this field 
pops up a list of bookmarks; click on the required one to go to the bookmark.

To jump to a specific page in the document, double-click on this field. The 
Navigator opens (see page 19). Click in the Page Number field in the Navigator 
and type the sequence number of the required page. After a brief delay, the 
display jumps to the selected page.

Page style
Shows the style of the current page. To change the page style, right-click on this 
field. A list of page styles pops up; choose a different style by clicking on it.

To edit the current page style, double-click on this field. The Page Style dialog box 
opens. See Chapter 6 and 7 in this book for more information about styles.

Language
Shows the language for the selected text.

Click to open a menu where you can choose another language for the selected text 
or for the paragraph where the cursor is located. You can also select None (Do 
not check spelling) to exclude the text from a spelling check or pick More to 
open the Character dialog box. See Chapter 3 (Working with Text) for more 
information.

Insert mode
Click to toggle between Insert and Overwrite modes when typing. In Insert mode, 
any text after the cursor position moves forward to make room for the text you 
type; in Overwrite mode, text after the cursor position is replaced by the text you 
type.

Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK 
(Block) selection. EXT is an alternative to Shift+click when selecting text. See 
Chapter 3 (Working with Text) for more information about these modes.

Unsaved changes
An asterisk (*) appears here if changes to the document have not been saved.

Digital signature

If the document has been digitally signed, an icon  shows here. To view the 
certificate, double-click the icon.
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Section or object information
When the cursor is in a section, heading, or list item, or when an object (such as a 
picture or table) is selected, information about that item appears in this field. 
Double-clicking in this area opens a relevant dialog box.

Object Information shown Dialog box opened

Picture Size and position Format Picture

List item Level and list style Bullets and Numbering1

Heading Outline numbering level Bullets and Numbering1

Table Name or number and cell 
reference of cursor

Table Format

Section Name of section Edit Sections

Other (Blank) Fields (Cross-References page)

View layout
Click an icon to change between single page, side-by-side, and book layout views. 
(See Figure 11.) You can edit the document in any view. Zoom settings (see below 
and next page) interact with the selected view layout to determine how many 
pages are visible in the document window.

Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – 
signs, or right-click on the zoom level percent to pop up a list of magnification 
values from which to choose.

1 If a list style was used with a list item or heading, no dialog box appears.
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Sidebar
The Sidebar brings together many functions that are otherwise available on several 
toolbars or menus. Its details are shown in Figure 12. It contains one or more decks, 
based on the current document context. Decks are organized into panels. A tab bar 
on the right side of the sidebar allows you to switch between different decks. The 
decks in Writer provide access to Properties, Styles, the Gallery, and the Navigator. 
More information about using these decks is provided in the appropriate chapters.

A panel is like a combination of a toolbar and a dialog. For example, you can freely 
mix working on the text in the main edit window and using the panels in the 
Properties or Styles decks in the Sidebar to change text attributes. The view of the 
Properties deck shown in Figure 12 is what appears when working with text. If you 
were to select a figure or a drawing shape, the panels would change to display 
properties such as position or fill colors that are appropriate for those objects. 

Toolbars and Sidebar panels share many functions. For example, the buttons for 
making text bold or italic are in both the Formatting toolbar and the Properties panel.

If the Sidebar is not visible, you can show it by using View > Sidebar on the menu 
bar. To hide the Sidebar, click on the gray Hide button on the left. Click on the same 
button to show the Sidebar again.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the 
Sidebar settings drop-down list at the top of the tab bar (see Figures 12 and 13). 
From the same list you can choose which items to show in the Sidebar.
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Changing Document Views

Writer has three ways to view a document: Print Layout, Web Layout, and Full 
Screen. To change the view, go to the View menu and click on the required view.

Print Layout is the default view in Writer. In this view, you can use the Zoom slider 
and the View Layout icons on the Status bar to change the magnification.

You can also choose View > Zoom from the menu bar to display the Zoom & View 
Layout dialog box (see Figure 14), where you can set the same options as on the 
Status bar.

In Web Layout view, you can use the Zoom slider; the View Layout buttons on the 
Status bar are disabled, and most of the choices on the Zoom & View Layout dialog 
box are not available.

In Full Screen view, the document is displayed using the zoom and layout settings 
previously selected. To exit Full Screen view and return to either Print or Web Layout 
view, press the Esc key or click the Full Screen icon in the top left-hand corner. You 
can also use Ctrl+Shift+J to enter or exit Full Screen view.
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Figure 13: Floating (undocking) or docking the 
Sidebar



Starting a New Document

You can start a new, blank document in Writer in several ways.

• From the operating system menu, in the same way that you start other 
programs. When AOO was installed on your computer, in most cases a menu 
entry for each component was added to your system menu. If you are using a 
Mac, you should see the OpenOffice icon in the Applications folder. When you 
double-click this icon, AOO opens at the Start Center (Figure 16).

• From the Quickstarter, which is found in Windows, some Linux distributions, 
and (in a slightly different form) in macOS. The Quickstarter is an icon that is 
placed in the system tray or the dock during system startup. It indicates that 
OpenOffice has been loaded and is ready to use.
Right-click the Quickstarter icon (Figure 15) in the system tray to open a pop-
up menu from which you can open a new document, open the Templates and 
Documents dialog box, or choose an existing document to open. You can also 
double-click the Quickstarter icon to display the Templates and Documents 
dialog box.
See Chapter 1 (Introducing OpenOffice) in the Getting Started guide for more 
information about starting Writer and using the Quickstarter.

Figure 15: Quickstarter pop-up menu on Windows 10

• From the Start Center. When AOO is open, but no document is open (for 
example, if you close all the open documents but leave the program running), 
the Start Center is shown. Click one of the icons to open a new document of 
that type, or click the Templates icon to start a new document using a 
template. If a document is already open in AOO, the new document opens in a 
new window.
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Figure 16: OpenOffice.org Start Center

When AOO is open, you can also start a new document in one of the following ways.

• Press the Control+N keys.

• Use File > New > Text Document.

• Click the New button on the main toolbar.

Starting a New Document from a Template
You can use templates to create new documents in Writer. A template is a set of 
predefined styles and formatting. Templates serve as the foundation of a set of 
documents, to make sure they all have a similar layout. For example, all the 
documents of the Writer Guide are based on the same template. As a result, all the 
documents look alike; they have the same headers and footers, use the same fonts, 
and so on.

A new OpenOffice installation does not contain many templates. It is possible for you 
to add new templates to your installation and use them for new documents. This is 
explained in Chapter 10 (Working with Templates). Many templates can be 
downloaded from https://extensions.openoffice.org/, and you can easily make your own.

Once you have templates on your system, you can create new documents based on 
them by using File > New > Templates and Documents. This opens a window 
where you can choose the template you want to use for your document.

The example shown in Figure 17 uses a template called “AOO41GS” in the My 
Templates folder. Select it, then click the Open button. A new document is created 
based on the styles and formats defined in the template.
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Figure 17. Creating a document from a template

Opening an Existing Document

When no document is open, the Start Center (Figure 16) provides an icon for opening 
an existing document or choosing from a list of recently-edited documents.

You can also open an existing document in one of the following ways. If a document is 
already open in AOO, the second document opens in a new window.

• Choose File > Open….

• Click the Open button on the main toolbar.

• Press Control+O on the keyboard.

• Use the Open Document or Recent Documents selections on the 
Quickstarter.

In each case, the Open dialog box appears. Select the file you want, and then click 
Open.

In the Open dialog box, you can reduce the list of files by selecting the type of file you 
are looking for. For example, if you choose Text documents as the file type, you will 
only see documents Writer can open (including *.odt, *.doc, *.txt). This method opens 
Word (*.doc) files as well as AOO files and other formats.

You can also open an existing Writer document using the same methods you would 
use to open any document in your operating system.

If you have associated Microsoft Office file formats with OpenOffice, you can also 
open these files by double-clicking on them.
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Saving a Document

To save a new document in Writer, do one of the following:

• Press Control+S.

• Choose File > Save.

• Click the Save button on the main toolbar.

When the Save As dialog box appears, enter the file name, verify the file type (if 
applicable), and click Save.

To save an open document with the current file name, choose File > Save. This will 
overwrite the last saved state of the file.

Saving a Document Automatically
You can choose to have Writer save a recovery copy of your document automatically 
at regular intervals. Automatic saving, unlike manual saving, does not overwrite the 
last saved state of the file. It saves a temporary version that can be recovered in case 
of a program crash. Using this feature does not replace periodically saving your 
work. To set up automatic file saving:

1) Select Tools > Options > Load/Save > General.
2) Click on Save AutoRecovery information every and set the time interval. 

The default value is 15 minutes. Enter the value you want by typing it or by 
pressing the up or down arrow keys.

Saving as a Microsoft Word Document
If you need to exchange files with users of Microsoft Word, they may not know how to 
open and save .odt files. Any version of Microsoft Word since Microsoft Office 2007 
with Service Pack 2 (SP2) can do this. 

Some users of Microsoft Word may be unwilling to work with *.odt files. In this case, 
you can save a document as a Microsoft Word file.

1) Important—First save your document in the file format used by AOO Writer, 
*.odt. If you do not, any changes you made since the last time you saved will 
only appear in the Microsoft Word version of the document.

2) Then click File > Save As.n the Save As dialog box, in the File type (or Save 
as type) drop-down menu, select the type of Word format you need.

3) Click Save.

From this point on, all changes you make to the document will occur only in the 
Microsoft Word document. You have changed the name and file type of your 
document. If you want to go back to working with the *.odt version of your document, 
you must open it again.

Tip

To have Writer save documents by default in the Microsoft Word file 
format, go to Tools > Options > Load/Save > General. In the 
section named Default file format and ODF settings, under 
Document type, select Text document, then under Always save as, 
select your preferred file format. Saving in a foreign format may lead 
to the loss of formatting, particularly with complex documents.
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Figure 18. Saving a file in Microsoft Word format

Password Protection

Writer provides two levels of document protection: read-protect (file cannot be 
viewed without a password) and write-protect (file can be viewed in read-only mode 
but cannot be changed without a password). Thus, you can make the content 
available for reading by a selected group of people and for reading and editing by a 
different group.

1) Use File > Save As when saving the document. (You can also use File > Save 
the first time you save a new document.)

2) On the Save As dialog box, select the Save with password option, and then 
click Save.

3) The Set Password dialog box opens.
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Figure 19: Two levels of password protection

Here you have several choices:
• To read-protect the document, type a password in the two fields at the top 

of the dialog box.

• To write-protect the document, click the More Options button and select 
the Open file read-only checkbox.

• To write-protect the document but allow selected people to edit it, select 
the Open file read-only checkbox and type a password in the two boxes at 
the bottom of the dialog box.

1) Click OK to save the file. If either pair of passwords do not match, you receive 
an error message. Close the message box to return to the Set Password dialog 
box and enter the password again.

Caution AOO uses a very strong encryption mechanism that makes it 
almost impossible to recover the contents of a document if 
you lose the password.
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Closing a Document

To close a document, choose File > Close or click the Close icon on the document 
window. In Windows, this icon looks like the X in the red box shown in Figure 20.

If more than one AOO window is open, each window looks like the sample shown on 
the left in Figure 20. Closing this window leaves the other AOO windows open.

If only one AOO window is open, it looks like the sample shown on the right in Figure 
20. Notice the small black X below the larger X in the red box. Clicking the small 
black X closes the document but leaves AOO open. Clicking the larger X closes AOO 
completely.

If the document has not been saved since the last change, a message box is 
displayed. Choose whether to save or discard your changes.

• Save: The document is saved and then closed.

• Discard: The document is closed, and all modifications since the last save are 
lost.

• Cancel: Nothing happens, and you return to the document.

Closing OpenOffice

To close AOO completely, click File > Exit, or close the last open document as 
described in “Closing a Document” above.

If all the documents have been saved, Writer closes immediately. If any documents 
have been modified but not saved, a warning message appears. Follow the procedure 
in “Closing a Document” to save or discard your changes.

Using the Navigator

In addition to the Page Number field on the Status bar (described on page 8), Writer 
provides other ways to move quickly through a document and find specific items by 
using the many features of the Navigator, the Navigation toolbar, and related icons.

The Navigator lists all the headings, tables, text frames, graphics, bookmarks, and 
other objects contained in a document.

To open the Navigator, click its icon  from the Sidebar tabs or on the Standard 
toolbar, or press F5, or choose View > Navigator on the menu bar, or double-click 
on the Page number field on the status bar. If the Navigator is displayed separately 
from the Sidebar, you can dock the Navigator to either side of the main Writer 
window or leave it floating (see “Docking/Floating Windows and Toolbars” on page 7).

To hide the list of categories and show only the icons at the top, click the List Box 

On/Off icon . This icon is not available in the Sidebar display of the Navigator 
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since it is unnecessary. Click this icon again to show the list. Click the + sign by any 
of the lists to display the contents of the list.

Table 1 summarizes the functions of the icons at the top of the Navigator.

Note The Navigator has different functions in a master document. See 
Chapter 13 (Working with Master Documents).

 

Figure 21. The Navigator 

Table 1: Function of icons in the Navigator

 

Toggle: Not active in ordinary documents (left image). In a master 
document (right image), switches between the master document file 
and its subdocuments.

Navigation: Opens the Navigation toolbar (see page 22).

Previous, Next: Jumps to the previous or next item in the selected 
category (page, graphic, hyperlink, comment, and so on). To select the 
category of items, see “Using the Navigation Toolbar“ on page 22.

Page number: Jumps to the page sequence number showing in the 
box. Type the required page number or select it using the up and down 
arrows.

Drag Mode: Select Hyperlink, Link, or Copy. See “Choosing Drag Mode” 
on page 23 for details.
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List Box On/Off: Shows or hides the list of categories.

Content View: Switches between showing all categories and showing 
only the selected category.

Set Reminder: Inserts a reminder (see page 23).

Header/Footer: Jumps between the text area and the header or footer 
area (if the page has them).

Anchor <–> Text: Jumps between a footnote anchor and the 
corresponding footnote text.

Heading Levels Shown: Choose the number of heading levels to be 
shown.

Moving Quickly through a Document
The Navigator provides several convenient ways to move around a document and find 
items in it:

• To jump to a specific page in the document, type its sequence number in the 
box at the top of the Navigator.

• When a category is showing the list of items in it, double-click on an item to 
jump directly to that item’s location in the document. For example, you can 
jump directly to a selected heading, graphic, or comment by using this method.
To see the content in only one category, highlight that category and click the 
Content View icon. Click the icon again to display all the categories. You can 
also change the number of heading levels shown when viewing Headings.

• Use the Previous and Next icons to jump to other objects of the type selected 
in the Navigation toolbar. (See below for details.)

Tip

Objects are much easier to find if you have given them names when 
creating them, instead of keeping AOO’s default names of graphics1, 
graphics2, Table1, Table2, and so on—which may not correspond to 
the position of the object in the document.

To rename an image, right-click on the image, select Picture > 
Options, and then edit the name in the dialog box. Similarly, to 
rename a table, right-click on the table, select Table > Table, and 
then edit the name.

Note
A hidden section (or other hidden object) in a document appears 
gray in the Navigator, and displays the word “hidden” as a tooltip. 
For more about hidden sections, see Chapter 4 (Formatting Pages).
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Using the Navigation Toolbar

To display the Navigation toolbar (Figure 22), click the Navigation icon  
(second icon from the left at the top of the Navigator, Figure 21) or the small 
Navigation icon near the lower right-hand corner of the window below the vertical 
scroll bar (Figure 23).

Figure 22: Navigation toolbar

The Navigation toolbar shows icons for all the object types shown in the Navigator, 
plus some extras (for example, the results of a Find command).

Click an icon to select that object type. Now all the Previous and Next icons (in the 
Navigator itself, in the Navigation Toolbar, and on the scroll bar) will jump to the 
previous or next object of the selected type. This is particularly helpful for finding 
items like index entries, which can be difficult to see in the text. The names of the 
icons (shown in the tooltips) change to match the selected category; for example, 
Next Graphic or Next Bookmark.

Rearranging Chapters Using the Navigator
You can rearrange chapters and move headings in the document by using the 
Navigator.

1) Click the Content View icon to expand the headings, if necessary.
2) (Optional) If you have several subheading levels, you can more easily find the 

headings you want, by changing the Heading Levels Shown selection to show 
only 1 or 2 levels of headings.

3) Click on the heading of the block of text that you want to move and drag the 
heading to a new location on the Navigator, or click the heading in the 
Navigator list, and then click either the Promote Chapter or Demote 
Chapter icon shown in Figure 24. All the text and subsections under the 
selected heading move with it.
To move only the selected heading and not the text associated with the 
heading, hold down Control, and then click the Promote or Demote icon.
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Tip

The tooltips Promote Chapter and Demote Chapter can be 
misleading; all headings—whether at Level 1 (chapter) or lower—can 
be rearranged using this function; and the feature might be better 
described as Move Up or Move Down (within the document, without 
changing the heading level) to distinguish it more clearly from 
Promote Level and Demote Level, which change the heading level 
within the document (see below).

4) To quickly change the outline level of a heading and its associated 
subheadings, select the heading in the Navigator, and then click either the 
Promote Level or Demote Level icon. This action does not change the 
location of the heading, only its level.

To increase the outline level of only the selected heading, but not its associated 
subheadings, hold down Control, and then click the icon.

Setting Reminders
One of the little-known features of Writer that you may find quite useful is the 
possibility of jumping between reminders. Reminders let you mark places in your 
document that you want to return to later on, to add or correct information, make 
some other change, or simply mark where you finished editing. The possible uses of 
reminders are limited only by your imagination.

To set a reminder at the cursor's current location, click on the  icon in the 
Navigator. You can set up to 5 reminders in a document; setting another causes the 
first to be deleted.

Reminders are not highlighted in any way in the document, so you cannot see where 
they are, except when you jump from one to the next—the location of the cursor then 
shows the location of the reminder.

To jump between reminders, first select the Reminder icon on the Navigation 
toolbar. Then click the Previous and Next icons.

Choosing Drag Mode
To select the drag and drop options for inserting items such as other documents and 
images, into a document using the Navigator, choose one of the following from the 

drop-down menu of the Drag Mode icon .

Insert As Hyperlink
Creates a hyperlink when you drag and drop an item into the current document.
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Insert As Link
Inserts the selected item as a link where you drag and drop in the current 
document. Text is inserted as protected sections. However, you cannot create links 
for graphics, OLE objects, references, or indexes using this method.

Insert As Copy
Inserts a copy of the selected item where you drag and drop in the current 
document. You cannot drag and drop copies of graphics, OLE objects, or indexes.

Getting Help

Writer provides several forms of help. In addition to a full Help file (reached by 
pressing F1 or choosing Help > OpenOffice Help from the menu bar), you can 
choose whether to activate tooltips, extended tips, and the Help Agent from Tools > 
Options > OpenOffice > General.

Placing the mouse pointer over any of the icons displays a small box, called a tooltip. 
It gives a brief explanation of the icon’s function. For a more detailed explanation, 
select Help > What’s This? and hold the mouse pointer over the icon you need more 
help with.

What Are All These Things Called?

The terms used in OpenOffice for most parts of the user interface (the parts of the 
program you see and use, in contrast to the behind-the-scenes code that actually 
makes it work) are the same as for most other programs.

A dialog box is a special type of window. Its purpose is to inform you of something, or 
request input from you, or both. It provides controls for you to use to specify how to 
carry out an action. The technical names for common controls are shown in Figure 
25; not shown is the list box (from which you select an item). In most cases we do not 
use the technical terms in this book, but it is useful to know them because the Help 
and other sources of information often use them.

In most cases, you can interact only with the dialog box (not the document itself) as 
long as the dialog box remains open. When you close the dialog box after use (usually, 
clicking OK or another button saves your changes and closes the dialog box), then 
you can again work with your document.

Some dialog boxes can be left open as you work, so you can switch back and forth 
between the dialog box and your document. An example of this type is the Find & 
Replace dialog box. The Sidebar also remains visible unless you choose to hide it.
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Undoing and Redoing Changes

When a document is open, you can undo the most recent change by pressing 

Control+Z, or clicking the Undo icon  on the Standard toolbar, or choosing Edit 
> Undo from the menu bar.

The Edit menu shows the latest change that can be undone. Click the small triangle 
to the right of the Undo icon to get a list of all the changes that can be undone. You 
can select multiple changes and undo them at the same time.
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After changes have been undone, Redo becomes active. To redo a change, select Edit 

> Redo, or press Control+Y or click on the Redo icon . As with Undo, click on the 
triangle to the right of the arrow to get a list of the changes that can be reapplied.

Using Writer on a Mac

Some keystrokes and menu items are different on a Mac from those used in Windows 
and Linux. The following table gives some common substitutions for the instructions 
in this book. For a more detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools > Options 
menu selection

OpenOffice > 
Preferences

Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open the Styles and Formatting 
window
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