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What is Writer?

Writer is the word processor component of OpenOffice.org (O0o0). In
addition to the usual features of a word processor (spelling check,
thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge, and others),
Writer provides these important features:

« Templates and styles

« Page-layout methods, including frames, columns, and tables

« Embedding or linking of graphics, spreadsheets, and other
objects

« Built-in drawing tools

« Master documents—to group a collection of documents into a
single document

« Change tracking during revisions

- Database integration, including a bibliography database

« Export to PDF, including bookmarks

+ And many more

Styles are central to using Writer. Using styles, you can easily format
your document consistently and change the format with minimal effort.
A style is a named set of formatting options. Writer defines several
types of styles, for different types of elements: characters, paragraphs,
pages, frames, and lists. Often, you are using styles whether you
realize it or not. The use of styles is described in more detail in
Chapter 6 (Introduction to Styles) and Chapter 7 (Working with Styles).

The other features of Writer listed above are also covered in detail in
other chapters of this guide.

Starting Writer

If you are reading this document in OpenOffice.org, you already know
how to start Writer. However, if this is a printed version or a PDF
version, you may not know how to start Writer. So let’s look at three
ways to do that:

« From the system menu
« From an existing document
« From the command line
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Starting from the system menu

The most common way to start Writer is by using the system menu,
the standard menu from which most applications are started. On
Windows, it is called the Start menu. On GNOME, it is called the
Applications menu. On KDE, it is identified by the KDE logo. On Mac
OS X, it is the Applications menu.

When OpenOffice.org was installed on your computer, in most cases a
menu entry for each component was added to your system menu. (If
you are using a Mac, see note below.) The exact name and location of
these menu entries depends on the operating system and graphical
environment.

Note for Mac users

You should see the OpenOffice.org icon in the Applications folder.
When you double-click this icon, a text document opens in Writer. To
open the other components (Draw, Calc, Impress, Base), go to the File
menu of the Writer window and select the component you want.

OOo does not automatically put a shortcut icon on the desktop, but you
can add one if you wish. If you don’t know how to add shortcut icons
for launching programs, please consult the help for your operating
system.

Starting from an existing document

All Writer documents are associated with the Writer application. This
means that you can start OpenOffice.org automatically, simply by
double-clicking a Writer document in a file manager such as Windows
Explorer.

You can spot an OpenOffice.org Writer document by its icon: {

Note for Windows users

If you have associated Microsoft Office file types with OOo, then when
you double-click on a *.doc (Word) file, it opens in OO0 Writer.

If you did not associate the file types, then when you double-click on a
Microsoft Word document, it opens in Microsoft Word (if Word is
installed on your computer).

You can use another method to open *.doc files in OOo and save in the
*.doc format from OOo. See “Opening an existing document” on page
24 for more information.
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Using the Quickstarter under Windows

The Quickstarter is an icon that is placed in the Windows system tray
during system startup. It indicates that OpenOffice.org has been
loaded and is ready to use. (The Quickstarter loads library *.DLL files
required by OOo, thus shortening the startup time for OOo components
by about half.) If the Quickstarter is disabled, see “Reactivating the
Quickstarter” on page 8 if you want to enable it.

Using the Quickstarter icon

Right-click the Quickstarter icon in the system tray to open a pop-up
menu from which you can open a new document, open the Templates
and Documents dialog box, or choose an existing document to open.
You can also double-click the Quickstarter icon to display the
Templates and Documents dialog box.

E Text Docurment

il Spreadsheet

a Presentation

E Drrawing

j&| Database

E Formula

ﬂ From Template...

i; Open Document, ..
v Load Opendffice,org During Syskem Skark-Up

= Exit Quickskarter

Figure 1: Quickstarter pop-up menu

Disabling the Quickstarter

To close the Quickstarter, right-click on the icon in the system tray and
then click Exit Quickstarter on the pop-up menu. The next time the
computer is restarted, the Quickstarter will be loaded again.

To prevent OpenOffice.org from loading during system startup,
deselect the Load OpenOffice.org During System Start-Up item on
the pop-up menu. You might want to do this if your computer has
insufficient memory, for example.
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Reactivating the Quickstarter

If the Quickstarter has been disabled, you can reactivate it by selecting
the Load OpenOffice.org during system start-up option in Tools >
Options > OpenOffice.org > Memory.

Using the Quickstarter under Linux

Some installations of OpenOffice.org under Linux have a Quickstarter
that looks and acts like the one described above for Windows (the
option on the Memory page is labeled Enable systray quickstarter).

Preloading OO0 under Linux/KDE

In Linux/KDE, you can use KDocker to have OOo loaded and ready for
use at startup. KDocker is not part of OOo; it is a generic “systray app
docker” that is helpful if you open OOo often.

Starting from the command line

You may want to start Writer from the command line (using the
keyboard instead of the mouse). Why? Well, by using the command
line, you have more control over what happens when Writer is started.
For example, using the command line, you can tell Writer to load a
document and print it immediately, or to start without showing the
splash screen.

Note Most users will never need to do this.

There is more than one way to start Writer from the command line,
depending on whether you have installed a customized version or the
standard download from the OOo web site.

If you installed using the download on the OO0 web site, you can start
Writer by typing at the command line:

soffice -writer
or
swriter

Writer will start and create a new document.

To see a list of options you can use when starting Writer at the
command line, type:

soffice -7?
Below is a list of some of the more popular options.
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Option Description

-help Get a complete list of options.

-nologo Do not show the startup screen.

-show <odp-file> Start presentation immediately.

-view <documents ...> | Open documents in viewer (read-only) mode.

-minimized Start OOo minimized.

-norestore Suppress restart/restore after fatal errors.

-invisible No startup screen, no default document and
no UI. This is useful for third-party
applications that use functionality provided
by OOo.

If you have a customized version of OOo (such as the one provided by
Linux Mandrake or Gentoo), you can start Writer by typing at the
command line:

oowriter

Although the command syntax differs, the effect is identical: it

Note starts OOo with an empty Writer document.

The Writer interface

The main Writer workspace is shown in Figure 2.

-Eile Edit \iew g Insert Fgrma.t Takble inols "._";.;'.indc-w éelp
B-EHd= CR RS- - B-@ O- BE-» ﬁ{i]u-ej[i]u{, &
EHUefau: EJ Times MNevli Roman EH"_-E E B/ & pe
=  ERERR NI S NOOE s AR 1

Standard toolbar | | Formatting toolbar

-

&

€ »
Pagel /1 Daefault English (LUSA) INSET | 5TD | *® (5] @t L o]

Figure 2: The main Writer workspace in Print Layout view
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Menus

The Menu bar is located across the top of the Writer window, just
below the Title bar. When you choose one of the menus listed below, a
submenu drops down to show commands.

« File contains commands that apply to the entire document such
as Open..., Save, and Export as PDF....

« Edit contains commands for editing the document such as Undo:
xxxX (where xxx is the command to undo) and Find &
Replace.... It also contains commands to cut, copy, and paste
selected parts of your document.

« View contains commands for controlling the display of the
document such as Zoom... and Web Layout.

« Insert contains commands for inserting elements into your
document such as headers, footers, and pictures.

« Format contains commands for formatting the layout of your
document, such as Styles and Formatting, Paragraph, and
Bullets and Numbering.

« Table shows all commands to insert and edit a table in a text
document.

« Tools contains functions such as Spelling and Grammar,
Customize..., and Options....

« Window contains commands for the display window.

« Help contains links to the OpenOffice.org Help file, What’s This?,
and information about the program. See “Getting help” on page
27.

Toolbars

Writer has several types of toolbars: docked, floating, and tear-off.
Docked toolbars can be moved to different locations or made to float,
and floating toolbars can be docked.

The top docked toolbar (default position) is called the Standard
toolbar. The Standard toolbar is consistent across the OpenOffice.org
applications (Writer, Calc, Draw, Impress, Base).

The second toolbar across the top (default location) is the Formatting
toolbar. It is a context-sensitive bar that shows the relevant tools in
response to the cursor’s current position or selection. For example,
when the cursor is on a graphic, the Formatting bar provides tools for
formatting graphics; when the cursor is in text, the tools are for
formatting text.
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Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the

name of a toolbar in the list. An active toolbar shows a check mark
beside its name. Tear-off toolbars are not listed in the View menu.

Submenus and tear-off toolbars

Toolbar icons with a small triangle to the right will display submenus,
tear-off toolbars, and other ways of selecting things, depending on the
icon. Figure 3 shows a tear-off toolbar from the Drawing toolbar.

Tear-off toolbars can be floating or docked along an edge of the screen
or in one of the existing toolbar areas. To move a floating tear-off
toolbar, drag it by the title bar. See “Moving toolbars” below.

Click here and drag Toolbar tears off and floats

\ —  p» Flowchart v X
O 0O < & RNE OO0 < Z 0.
OO0 Cdvw O OF O e
OCU AR DB U AdXA® dB
X < A VRN X o AV OaDbD
Qg ao Qg oo
O -0 - % - X & H-O- % -2 &

Figure 3: Example of a tear-off toolbar

Moving toolbars

To move a docked toolbar, place the mouse pointer over the toolbar
handle, hold down the left mouse button, drag the toolbar to the new
location, and then release the mouse button (Figure 4).

To move a floating toolbar, click on its title bar and drag it to a new
location (Figure 5).
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Handles of docked toolbars

i Untitled 1 - OpenOffice.org Writer
File Edit View Insert Format Table Tools Window Help

B-E2HE® B8R ¥E is
. 4 | Default [=| | centSchbook BT (=] 11

Figure 4: Moving a docked toolbar

Title bar of floating toolbar

Bullets and Mumberin \ * X

g

=~ T 1 4 % BEE

Figure 5: Moving a floating toolbar
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Floating toolbars

Writer includes several additional context-sensitive toolbars, whose
defaults appear as floating toolbars in response to the cursor’s current
position or selection. For example, when the cursor is in a table, a
floating Table toolbar appears, and when the cursor is in a numbered
or bullet list, the Bullets and Numbering toolbar appears. You can dock
these toolbars to the top, bottom, or side of the window, if you wish
(see “Moving toolbars” on page 11).

Docking/floating windows and toolbars

Toolbars and some windows, such as the Navigator and the Styles and
Formatting window, are dockable. You can move, resize, or dock them
to an edge.
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To dock a window, do one of the S R

following: _

« Click on the title bar of the e meaﬁmf_
floating window and drag it to @u el W e
the side until you see the outline mplimentary close
of a box appear in the main Firet line indent
window and then release the Hanging indent
window. This method depends Hendin 1
on your system’s window Heading 10
manager settings, so it may not Heding 5
work for you. Heading 4

+ Hold down the Control key and | neeina?
double-click on a vacant part of [Automatic

the floating window to dock it in
its last position. If that does not
work, try double-clicking

without using the Control key.
Figure 6: Docking a window

To undock a window, hold down the
Control key and double-click on a
vacant part of the docked window.

The Styles and Formatting window can also be docked or
Note undocked by using Control+double-click on the gray area next to
the icons at the top of the window.

Customizing toolbars

You can customize toolbars in several ways, including choosing which
icons are visible and locking the position of a docked toolbar. You can
also add icons and create new toolbars, as described in Appendix B.

To access a toolbar’s customization options, use the down-arrow at the
end of the toolbar or on its title bar.

Toolbar customization icons

T | _'ﬂ_"
b dF | BE R

Figure 7: Customizing toolbars

To show or hide icons defined for the selected toolbar, choose Visible
Buttons from the drop-down menu. Visible icons have a checkmark
next to them. Click on icons to select or deselect them.
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Right-click (context) menus

You can quickly access many menu functions by right-clicking on a
paragraph, graphic, or other object. A context menu will pop up. Often
the context menu is the fastest and easiest way to reach a function. If
you're not sure where in the menus or toolbars a function is located,
you can often find it by right-clicking.

Rulers

To show or hide rulers, choose View > Ruler. To enable the vertical
ruler, choose Tools > Options > OpenOffice.org Writer > View and
select Vertical ruler.

Guides View
[ ] Guides while moving Horizontal scrollbar
Simple handles Vertical scrollbar
[ ] Large handles Ruler
Display Horizontal ruler inch W
Graphics and objects Vertical ruler inch bl
Tables [ ] smooth scrall
Drawings and controls
[] Eield codes
Motes

Figure 8. Turning on the vertical ruler

Status bar

The Writer status bar provides information about the document and
convenient ways to quickly change some document features. From left
to right, the fields are as follows.

Page 3 [ 14 DEF_aull: English {I15&) INSRT STD | ¥
Page number Page style  Language Insert  Selection Unsaved
mode  mode changes

Figure 9: Left end of status bar

Page number
Shows the current page number, the sequence number of the
current page (if different), and the total number of pages in the
document. For example, if you restarted page numbering at 1 on the
third page, its page number is 1 and its sequence number is 3.
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If any bookmarks have been defined in the document, a right-click
on this field pops up a list of bookmarks; click on the required one.

To jump to a specific page in the document, double-click on this
field. The Navigator opens (see page 17). Click in the Page Number
field and type the sequence number of the required page. After a
brief delay, the display jumps to the selected page.

Page style

Shows the style of the current page. To change the page style, right-
click on this field. A list of page styles pops up; choose a different
style by clicking on it.

To edit the current page style, double-click on this field. The Page
Style dialog box opens.

Language

Shows the language for the selected text.

Click to open a menu where you can choose another language for
the selected text or for the paragraph where the cursor is located.
You can also choose None (Do not check spelling) to exclude the
text from a spelling check or choose More... to open the Character
dialog box.

Insert mode

Click to toggle between Insert and Overwrite modes when typing.

Selection mode

Click to toggle between STD (Standard), EXT (Extend), ADD (Add)
and BLK (Block) selection. EXT is an alternative to Shift+click when
selecting text. See Chapter 3 (Working with Text) for more
information about ADD and BLK.

Unsaved changes

An asterisk (*) appears here if changes to the document have not
been saved.

Outline Mumbering : Level 2 B GE6ECE ||&n 9 ] 120% ”
Digital Object View Zoom Zoom
signature Inform ation laty out slider percent

Figure 10: Right end of status bar
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Digital signature

If the document has been digitally signed, an icon %/ shows here.
You can double-click the icon to view the certificate.

Section or object information
When the cursor is on a section, heading, or list item, or when an
object (such as a picture or table) is selected, information about that

item appears in this field. Double-clicking in this area opens a
relevant dialog box.

Object Information shown Dialog box opened
Picture Size and position Format Picture
List item Level and list style Bullets and Numbering!
Heading Outline numbering level Bullets and Numbering!
Table Name or number and cell Table Format
reference of cursor
Section Name of section Edit Sections
Other (Blank) Fields (Cross References page)

View layout

Click an icon to change between single page, side-by-side, and book
layout views (Figure 11). You can edit the document in any view.

D!...:ii ._IEIEI_l_. .II:.||j:—!
- ] -

1 1 2 1

Figure 11. View layouts: single, side-by-side, book

Zoom

To change the view magnification, drag the Zoom slider, or click on
the + and - signs, or right-click on the zoom level percent to pop up

1 If a list style was used with a list item or heading, no dialog box appears.
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a list of magnification values from which to choose. Zoom interacts
with the selected view layout to determine how many pages are
visible in the document window.

& o ® [100%

Changing document views

Writer has several ways to view a document: Print Layout, Web Layout,
and Full Screen. To access these and other choices, go to the View
menu and click on the required view. (When in Full Screen view, press
the Esc key to return to either Print or Web Layout view.)

When in Print Layout, you can use both the Zoom slider and the View
Layout icons on the Status bar. In Web Layout, you can use the Zoom
slider.

You can also choose View > Zoom from the menu bar to display the
Zoom & View Layout dialog box (see Figure 12), where you can set the
same options as on the Status bar. In Web Layout view, most of the
choices are not available.

Zoormn & View Layout

Zoom factor

View layout

O Optimal O Automatic

(O Eit width and height & Single page

O Fit width O Columns > -
® 100 % O

i Variable 100%

oK

Cancel | |

Help

Figure 12. Choosing Zoom and View Layout options

Using the Navigator

In addition to the Page Number field on the Status bar (described on
page 14), Writer provides other ways to move quickly through a
document and find specific items by using the many features of the

Navigator, the Navigation toolbar, and related icons.

Using the Navigator
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The Navigator lists all of the headings, tables, text frames, graphics,
bookmarks, and other objects contained in a document.

To open the Navigator, click its icon @ on the Standard toolbar, or
press F5, or choose View > Navigator on the menu bar, or double-
click on the Page number field on the status bar. You can dock the
Navigator to either side of the main Writer window or leave it floating
(see “Docking/floating windows and toolbars” on page 12).

To hide the list of categories and show only the icons at the top, click
the List Box On/Off icon ) Click this icon again to show the list.
Click the + sign by any of the lists to display the contents of the list.

Table 1 summarizes the functions of the icons at the top of the
Navigator.

The Navigator has different functions in a master document. See

Note Chapter 13 (Working with Master Documents).

Novigror =
O -8 17 & e-

F&E ¢ &=5 =-
=

Preface
Why use OpenOffice.org?
What do you need to do first?
Other sources of information

Acknowledgments
1 Introduction to Writer

B Tables

[] Text frames

Bl Graphics

il OLE objects

ﬁ Bookmarks

= Sections

*

=

&5 Hyperlinks
§'§ References
?E, Indexes

5

|=] MNotes
E@ Craw ohjects

|Te5tD ocfl} (active) Izl

Figure 13. The Navigator
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Table 1: Function of icons in the Navigator

Not active in ordinary documents. In a master document, switches
between the master document file and its subdocuments.

o - Opens the Navigation toolbar (see page 20).

1 Jumps to the previous or next item in the document. To select the
=S category of items, see “Using the Navigation toolbar” on page 20.

= Jumps to the page number in the box. Type the page number or
b select it using the up and down arrows.

Drag Mode. Select hyperlink, link, or copy. See “Choosing drag

= mode” on page 22 for details.

=] List Box On/Off. Shows or hides the list of categories.

FE] Content View. Switches between showing all categories and

= showing only the selected category.

& Inserts a reminder (see page 21).

g [z Jumps between the text area and the header or footer area (if the

page has them).

Jumps between a footnote anchor and the corresponding footnote
text.

|| 0

Choose the number of heading levels to be shown.

Moving quickly through a document

The Navigator provides several convenient ways to move around a
document and find items in it:

« To jump to a specific page in the document, type its sequence
number in the box at the top of the Navigator.

« When a category is showing the list of objects in it, double-click
on an object to jump directly to that object’s location in the
document.

To see the content in only one category, highlight that category
and click the Content View icon. Click the icon again to display
all the categories. You can also change the number of heading
levels shown when viewing Headings.

« Use the Previous and Next icons to jump to other objects of the
type selected in the Navigation toolbar. (See below for details.)
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Objects are much easier to find if you have given them names
when creating them, instead of keeping OOo0’s default names of
graphics1, graphics2, Tablel, Table2, and so on—which may not
correspond to the position of the object in the document.

Tip

A hidden section (or other hidden object) in a document appears
Note gray in the Navigator, and displays the word “hidden” as a
tooltip.

Using the Navigation toolbar

To display the Navigation toolbar, click the Navigation icon O -
(second icon from the left at the top of the Navigator. Figure 13) or the
small Navigation icon near the lower right-hand corner of the window
below the vertical scroll bar (Figure 14).

Pr emcus—@
Next—[ﬁ'\,

Mavigation

OO0 (| <) @ || 100%

Figure 14: Previous, Navigation, and Next icons

Navigation )

EoOw Wb OE & wee 8

=S PEEHDRSEERES
Fage

Figure 15: Navigation toolbar

The Navigation toolbar (Figure 15) shows icons for all the object types
shown in the Navigator, plus some extras (for example, the results of a
Find command).

Click an icon to select that object type. Now all the Previous and Next
icons (in the Navigator itself, in the Navigation Toolbar, and on the
scroll bar) will jump to the next object of the selected type. This is
particularly helpful for finding items like index entries, which can be
difficult to see in the text. The names of the icons (shown in the
tooltips) change to match the selected category; for example, Next
Graphic or Next Bookmark.
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Rearranging chapters using the Navigator

You can arrange chapters and move headings in the document by using
the Navigator.

1)
2)

3)

Click the Content View icon to expand the headings, if necessary.

(Optional) If you have several subheading levels, you can more
easily find the headings you want, by changing the Heading
Levels Shown selection to show only 1 or 2 levels of headings.

Click on the heading of the block of text that you want to move
and drag the heading to a new location on the Navigator, or click
the heading in the Navigator list, and then click either the
Promote Chapter or Demote Chapter icon. All of the text and
subsections under the selected heading move with it.

To move only the selected heading and not the text associated
with the heading, hold down Control, and then click the icon.

The tooltips (Promote Chapter and Demote Chapter) are

Tip misleading; all headings defined in Tools > Outline

Numbering can be rearranged using this function.

4) To quickly change the outline level of a heading and its associated

subheadings, select the heading in the Navigator, and then click
either the Promote Level or Demote Level icon. This action
does not change the location of the heading, only its level.

To increase the outline level of only the selected heading, but not
its associated subheadings, hold down Control, and then click the
icon.

Promote| _ . |Demote

chapterp==:; =={chapter

Promote] ‘. =’_|Demote
level level

Figure 16. Reorganizing with the Navigator

Note

Users of MS Office Word will note the similarity between this
functionality and Word's Outline View.

Setting reminders

One of the little known features of Writer which you may find quite
useful is the possibility of jumping between reminders. Reminders let
you mark places in your document that you want to return to later on,
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to add or correct information, make some other change, or simply
mark where you finished editing. The possible uses of reminders are
limited only by your imagination.

To set a reminder at the cursor's current location, click on the
icon in the Navigator. You can set up to 5 reminders in a document
(setting another causes the first to be deleted).

Reminders are not highlighted in any way in the document, so you
cannot see where they are, except when you jump from one to the next
—the location of the cursor then shows the location of the reminder.

To jump between reminders, first select the Reminder icon on the
Navigation toolbar. Then click the Previous and Next icons.

Choosing drag mode

Sets the drag and drop options for inserting items into a document
using the Navigator.

Insert As Hyperlink
Creates a hyperlink when you drag and drop an item into the
current document.

Insert As Link
Inserts the selected item as a link where you drag and drop in the
current document. Text is inserted as protected sections. However,
you cannot create links for graphics, OLE objects, references, or
indexes using this method.

Insert As Copy
Inserts a copy of the selected item where you drag and drop in the
current document. You cannot drag and drop copies of graphics,
OLE objects, or indexes.

Starting a new document

Creating a blank document
You can create a new, blank document in Writer in several ways.

When OOo is open but no document is open (for example, if you close
all the open documents but leave the program running), a Welcome
screen is shown. Click one of the icons to open a new document of that
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type, or click the Templates icon to start a new document using a
template.

You can also start a new document in one of the following ways. If a
document is already open in OOo, the new document opens in a new
window.

« Press the Control+N keys. A new empty document opens. If you
already have a document open, the new document appears in a
new window.

« Use File > New > Text Document. The result is the same as
pressing the Control+N keys.

« C(Click the New button on the main toolbar { ;

Creating a document from a template

You can use templates to create new documents in Writer. Templates
serve as the foundation of a set of documents, to make sure they all
have a similar layout. For example, all the documents of the Writer
Guide are based on the same template. As a result, all the documents
look alike; they have the same headers and footers, use the same fonts,
and so on.

A new OpenOffice.org installation does not contain many templates. It
is possible for you to add new templates to your installation and use
them for new documents. This is explained in Chapter 10 (Working
with Templates). Many more templates can be downloaded from
http://extensions.services.openoffice.org/ and other websites.

Once you do have templates on your system, you can create new
documents based on them by using File > New > Templates and
Documents. This opens a window where you can choose the template
you want to use for your document.

The example shown in Figure 17 uses a template called “Book” in the
My Templates folder. Select it, then click the Open button. A new
document is created based on the formats defined in the template.
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Figure 17. Creating a document from a template

Opening an existing document

When no document is open, the Welcome screen provides an icon for
opening an existing document.

You can also open an existing document in one of the following ways. If
a document is already open in OOo, the second document opens in a
new window.

« Click File > Open....
« Click the Open button on the main toolbar.
s Press Control+0O on the keyboard.

In each case, the Open dialog box appears. Select the file you want,
and then click Open.

In the Open dialog box, you can reduce the list of files by selecting the
type of file you are looking for. For example, if you choose Text
documents as the file type, you will only see documents Writer can
open (including *.odt, *.doc, *.txt). This method opens Word (*.doc)
files, as well as OOo files and other formats.
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You can also open an existing OOo Writer document using the same
methods you would use to open any document in your operating
system.

If you have associated Microsoft Office file formats with
OpenOffice.org, you can also open these files by double-clicking on
them.

Saving a document

To save a new document in Writer, do one of the following:
« Press Control+S.
« Select File > Save.
« Click the Save button on the main toolbar.

When the Save As dialog box appears, enter the file name and verify
the file type (if applicable).

To save an open document with the current file name, choose File >
Save. This will overwrite the last saved state of the file.

Password protection

To protect an entire document from being viewable without a
password, use the option on the Save As dialog box to enter a
password. This option is only available for files saved in
OpenDocument formats or the older OpenOffice.org 1.x formats.

1) On the Save As dialog box, select the Save with password
option, and then click Save. You will receive a prompt:

o iy}

Enter Password

Enker password

Reenter password

WARMING: If wou lose or Forget the password, it
cannaot be recovered. It is advisable to keep
passwords in a safe place, Passwords are case-sensi. ..

I, Cancel | | Help
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2) Type the same password in the two fields, and then click OK. If
the passwords match, the document is saved password protected.
If the passwords do not match, you receive the prompt to enter
the password again.

Passwords must contain a minimum of 5 characters. Until you

Note have entered 5 characters, the OK button remains inactive.

OOo uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document in case you lose the
password.

Saving a document automatically

You can choose to have Writer save your document automatically at
regular intervals. Automatic saving, like manual saving, overwrites the
last saved state of the file. To set up automatic file saving:

1) Select Tools > Options > Load/Save > General.

2) Click on Save AutoRecovery information every and set the
time interval. The default value is 15 minutes. Enter the value you
want by typing it or by pressing the up or down arrow keys.

Saving as a Microsoft Word document

If you need to exchange files with users of Microsoft Word, they may
not know how to open and save .odt files. Microsoft Word 2007 with
Service Pack 2 (SP2) can do this. Users of Word 2007, 2003, XP, and
2000 can also download and install a free OpenDocument Format
(ODF) plugin from Sun Microsystems.

Some users of Microsoft Word may be unwilling or unable to receive
*.0dt files. (Perhaps their employer won’t allow them to install the
plug-in.) In this case, you can save a document as a Microsoft Word
file.

1) Important—First save your document in the file format used by
OO0 Writer, *.odt. If you do not, any changes you made since the
last time you saved will only appear in the Microsoft Word version
of the document.

2) Then click File > Save As.

3) On the Save As dialog box, in the File type (or Save as type)
drop-down menu, select the type of Word format you need.

4) Click Save.
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From this point on, all changes you make to the document will occur
only in the Microsoft Word document. You have changed the name and
file type of your document. If you want to go back to working with the
*.0dt version of your document, you must open it again.

To have Writer save documents by default in the Microsoft Word
file format, go to Tools > Options > Load/Save > General. In

Tip the section named Default file format, under Document type,
select Text document, then under Always save as, select your
preferred file format.

- -

Save as
D:'\Document Files\Microsoft Office
Title Type |5ize
[ Auto Save Folder
(21 Family Folder
[ Graphic Images Folder
[ Miscellaneous Folder
[ outlock Folder
[ Templates Folder

File name: chapter_template_V2 w
File type: OpenDocument Text {.odt) W
OpenDocument Text [ odt) ”
OpenDocument Text Template {Lott)

OpenOffice.org 1.0 Text Document { sxw)

OpenQffice.org 1.0 Text Document Template (.stw)

Microsoft Word 97/2000/%P (.doc)

Microsoft Word 95 (. doc)

Microsaft Ward 6.0 (.doc)

Rich Text Format (.rif)

StarWriter 5.0 (.sdw)

StarWriter 5.0 Template { var) bl

Figure 18. Saving a file in Microsoft Word format

[ ] 5ave with passwo

Getting help

Writer provides several forms of help. In addition to a full Help file
(reached by pressing F1 or choosing Help > OpenOffice.org Help
from the menu bar), you can choose whether to activate tooltips,
extended tips, and the Help Agent from Tools > Options >
OpenOffice.org > General.

Placing the mouse pointer over any of the icons displays a small box,
called a tooltip. It gives a brief explanation of the icon’s function. For a
more detailed explanation, select Help > What’s This? and hold the
mouse pointer over the icon you need more help with.
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Undoing and redoing changes

When a document is open, you can undo the most recent change by

pressing Control+Z, or clicking the Undo icon % on the Standard
toolbar, or choosing Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone.

[= Untitled1 - OpenOffice.org Writer

File Edit View Insert Format Table Tt
t’: 49 Undo: Delete 'rabbit’ Ctrl+2
: # Redo: Typing: 'fox'  Ctrl+Y
Figure 19: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all
the changes that can be undone. You can select multiple changes and
undo them at the same time.

- & ¥ M [k &

Paste dipboard

Delete 51

Change style: graphics17
Insert graphics

Delete graphics

Undo 1 action

Figure 20: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a
change, select Edit > Redo, or press Control+Y or click on the Redo

icon a As with Undo, click on the triangle to the right of the arrow to
get a list of the changes that can be reapplied.

Closing a document

To close a document, click File > Close.

You can also close a document by clicking on the Close icon on the
document window. In Windows XP, this button looks like the X in the
red box shown in Figure 21.
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If more than one OOo window is open, each window looks like the
sample shown on the left in Figure 21. Closing this window leaves the
other OO0 windows open.

If only one OO0 window is open, it looks like the sample shown on the
right in Figure 21. Notice the small black X below the larger X in the
red box. Clicking the small black X closes the document but leaves
OOo open. Clicking the larger X closes OO0 completely.

== X == x)

A

Figure 21. Close icons

If the document has not been saved since the last change, a message
box is displayed. Choose whether to save or discard your changes.

« Save: The document is saved and then closed.

« Discard: The document is closed, and all modifications since the
last save are lost.

« Cancel: Nothing happens, and you return to the document.

Caution Not saving your document could result in the loss of recently
A made changes, or worse still, your entire file.

Closing Writer

To close Writer completely, click File > Exit, or close the last open
document as described in “Closing a document” on page 28.

If all the documents have been saved, Writer closes immediately. If any
documents have been modified but not saved, a warning message
appears. Follow the procedure in “Closing a document” to save or
discard your changes.
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